ROOT fails after upgrade to MacOS Ventura

Platform: MacOS Ventura 13.0

After upgrading my Mac software to MacOS to Ventura 13.0, my ROOT fails to work.
I encountered the same issue when I upgraded to macOS Monterey, but by installing Command Line Tools for Xcode 13.0 from Apple Dev website I resolved the problem.
I tried to do the same this time, but when installing I get the following message: " Command Line Tools can’t be installed on this disk. The version of macOS is too new".
How can I resolve this issue?
Thank you!

I have installed 13.0 on my laptop, and recompiled ROOT master branch, and all is fine. ROOT runs.

% sw_vers
ProductName:		macOS
ProductVersion:		13.0
BuildVersion:		22A380
% root
  | Welcome to ROOT 6.27/01               |
  | (c) 1995-2022, The ROOT Team; conception: R. Brun, F. Rademakers |
  | Built for macosx64 on Oct 26 2022, 14:14:39                      |
  | From heads/master@v6-25-02-2656-g233019e478                      |
  | With Apple clang version 12.0.5 (clang-1205.0.22.9)              |
  | Try '.help'/'.?', '.demo', '.license', '.credits', '.quit'/'.q'  |

root [0] 

Do you have Xcode 14.0.1 and the most updated version of Command Line Tools?
And how do I recompile ROOT master branch? I’m sorry, I’m kind of new to this.

I tried to update ROOT via homebrew, and successfully upgraded root 6.24.06 → 6.26.06_1.
This allowed me to run ROOT normally again.
However, while trying to run a project I made a while ago, I got the following error:

*** Break *** segmentation violation
[/usr/lib/system/libsystem_platform.dylib] _sigtramp (no debug info)
[] (no debug info)
[/Users/marcocosta/Desktop/C02/projecto/bin/projecto.exe] pendulum_parametric::Draw(bool, double) (no debug info)
[/Users/marcocosta/Desktop/C02/projecto/bin/projecto.exe] main (no debug info)

Then I tried to run another project and got the following error:

*** Break *** segmentation violation
[/usr/lib/system/libsystem_platform.dylib] _sigtramp (no debug info)
[/usr/local/Cellar/root/6.26.06_1/lib/root/] TList::NewLink(TObject*, std::__1::shared_ptr const&) (no debug info)
[/usr/local/Cellar/root/6.26.06_1/lib/root/] TPad::WaitPrimitive(char const*, char const*) (no debug info)
[/Users/marcocosta/Desktop/C02/bin/HW3.exe] main (no debug info)
[/usr/lib/dyld] start (no debug info)

These scripts were fine before the upgrade and now I cannot get them to run. How can I solve this?

Can you post the script showing the problem ? (108.2 KB)
In this folder, the first error comes from running “make projecto” in the “projecto” subfolder.
The second error comes from running “make bin/HW3.exe” in the folder I sent you.
Both of these used to run just fine, I just started having problems after upgrading my Root version after upgrading MacOS version.

I get warnings when I do that.

This I do not understand…

I also have the same problem. With the newest Xcode 14.1 and the newest root 6.26.00_1 in Ventura, When I run “root --version”, I encounter the following problem:

**input_line_1:1:2:** **error:** **module 'Darwin' uses additional module map '/Applications/' used when**

**the module was built**

#include <new>


**input_line_1:1:2: note:** imported by module 'std' in '/usr/local/Cellar/root/6.26.00_1/lib/root/std.pcm'

Warning in cling::IncrementalParser::CheckABICompatibility():

Failed to extract C++ standard library version.

Warning in cling::IncrementalParser::CheckABICompatibility():

Possible C++ standard library mismatch, compiled with _LIBCPP_ABI_VERSION '1'

Extraction of runtime standard library version was: ''

**input_line_2:1:2:** **fatal error:** **module file '/usr/local/Cellar/root/6.26.00_1/lib/root/std.pcm' is out of date and needs to be rebuilt**

#include "cling/Interpreter/RuntimeUniverse.h"


**input_line_2:1:2: note:** imported by module 'Cling_Runtime_Extra' in '/usr/local/Cellar/root/6.26.00_1/lib/root/Cling_Runtime_Extra.pcm'

**input_line_2:1:2: note:** imported by module 'Cling_Runtime' in '/usr/local/Cellar/root/6.26.00_1/lib/root/Cling_Runtime.pcm'

Replaced symbol atexit cannot be found in JIT!

Replaced symbol at_quick_exit cannot be found in JIT!

<<< cling interactive line includer >>>: **fatal error:** **module file '/usr/local/Cellar/root/6.26.00_1/lib/root/Darwin.pcm' is out of date and needs to be rebuilt**

Failed to load module Darwin

Failed to load module std

This time, not relevant to /CommandLineTools.

Hello, I got the same issue now, can you let me know how to solve this problem??

I resolved the issue by updating my version of root and Xcode, since I had older ones.
Furthermore, I still had problems running specific programs that needed root, but I fixed that by deleting and recompiling my code library, which had been previously recompiled with the older version of root.
If you have the most up-to-date root version, I would then suggest reinstalling it, besides recompiling any library you might have.

Okay. I will reinstall it now, but could you please let me know how to recompiling any library I might have?
I am the new one who are not familiar with this.

Hi @Byungchul_Yu ,

and welcome to the ROOT forum. We can continue the discussion at Problem running ROOT on Mac OS Ventura 13.0 , but please also check [official] ROOT on MacOS Ventura 13.0 .


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.