ROOT configuration failed

Good Morning all,

I’ve tried to install ROOT on my Macbook using the information provided at the proper link ( it seems I cannot post this link since I am a new user) under the section Conda and I created an environment as suggested in the section that I just mentioned.
After that i created a .ipynb to start playing: I activated the environment that i created and I tried to import ROOT with import ROOT/, but it takes so much time that I decided to stop the process. Even single imports like from ROOT import gROOt were incredible slow and I stopped them too.

I tried to install ROOT directly from the notebook with conda install ROOT having the following output:

Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: / 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:


  - argon2-cffi-bindings -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.5,<3.6.0a0']
  - asttokens -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0|>=3.7,<3.8.0a0|>=3.5,<3.6.0a0']
  - cached-property -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0|>=3.5,<3.6.0a0']
  - fqdn -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0|>=3.5,<3.6.0a0']
  - importlib_metadata -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0']
  - pexpect -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.5,<3.6.0a0']
  - platformdirs -> python[version='>=3.12,<3.13.0a0']
  - ptyprocess -> python[version='>=2.7,<2.8.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.6,<3.7.0a0|>=3.5,<3.6.0a0']
  - python-dateutil -> python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']
Note that strict channel priority may have removed packages required for satisfiability.

Note: you may need to restart the kernel to use updated packages. ```

Have you any idea on which could be the possible error I'm making?

Thank you very much,

Hello @LeonardoPlini,
welcome on the ROOT forum!
Looking at the error message raised by conda, it seems that your python version in incompatible with some of the packages required. Can you provide the python version available in your environment? Did you follow the instructions reported here for the installation?


Hi @mdessole,
Thank you ! I’ve followed the instructions at the link that you posted and I’m using python 3.11.6.
Nevertheless, I solved the problem by downloading Xcode from the App Store and launching it.

Thank you for your reply and the support,