Home | News | Documentation | Download

"ROOT component Eve not found" error while building Delphes

Hello!

I tried to build Delphes from source (with ROOT previously installed) using cmake, but the error appeared:

“ROOT component Eve not found”.

It makes installation not possible and I wonder how to add a particular component and solve the problem.

ROOT Version: 6.24/06
Platform: Ubuntu 20.04
Compiler: gcc 9.3.0

Hi @Kamil180400 ,
and welcome to the ROOT forum!
For some reason, your ROOT installation does not include the Eve component. You will need a different ROOT installation, as Delphes seems to require Eve (and it’s not possible to add ROOT features to an existing installation).

Cheers,
Enrico

Hi!
Thank you for your response.
After the installation od Delphes using cmake failed, because of problem I have described in previous message, I tried to use make command in Delphes-3.5.0 directory and installation was completed without any errors. I have some problems in using Delphes libraries in ROOT, so I guess there is still some problem with missing ROOT components. I built ROOT from source with cmake on my UBUNTU 20.04 so I actually don’t have idea how to install it in different way. Should I use a pre-compiled version of ROOT instead?

All best,
Kamil

Hi,
sounds like you worked around Delphes’ checks for the presence of required ROOT components, but those checks were there for a reason :smiley:

When you give the cmake configure command it says which components are active and which not (and usually it also says why a component has been disabled, e.g. because some dependency is missing).

For Eve to be enabled, you need cmake to say “Enabled support for: … opengl …”, i.e. you need OpenGL.

A pre-compiled version should have everything you need but you will still need to install all ROOT dependencies on your system, see Dependencies - ROOT .

Cheers,
Enrico