Root compile

I just grabbed the latest version of stable root 5.14 from the home page and was going to compile it… The platform is:

Fermi Linux 731 INSTALL for FermiStandAlone via CDROM on Thu Jul  1 11:46:06 CDT 2004Fermi Linux 731 INSTALL for FermiStandAlone via CDROM on Thu Jul  1 11:46:06 CDT 2004

-rwxr-xr-x    1 root     root      1260480 Oct 14  2004 /lib/
lrwxrwxrwx    1 root     root           13 Dec  1  2004 /lib/ ->

[prophecy@kuhep10 etc]$ gcc --version

I was following the documentation (just to make sure that I did not make a mistake) and ran the following command

export ROOTSYS='pwd`
./configure linux --disable-xrootd

This finishes correctly and when I try to compile I get the following error…

[prophecy@kuhep10 vanilla]$ gmake
bin/rmkdepend -R -fcint/src/Api.d -Y -w 1000 -- -pipe -Wall -W -Woverloaded-virtual -fPIC -Iinclude  -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -Icint/src -pthread -D__cplusplus -- cint/src/Api.cxx
g++ -O  -pipe -Wall -W -Woverloaded-virtual -fPIC -Iinclude  -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -Icint/src -pthread -o cint/src/Api.o -c cint/src/Api.cxx
In file included from cint/src/Api.cxx:16:
include/Api.h:21:19: ostream: No such file or directory
gmake: *** [cint/src/Api.o] Error 1

I do not remember ever getting the error before. Now, I did do a search for just plain ostream and I found only


Any help on this would be greatfull. Thanks in advance.


Shouldn’t configure automatically determine whether I use ostream or ostream.h? I know they are just different versions of the same think using different forms.

It looks like you are mixing gcc2.96 (not supported anymore) and gcc3.xx
Make sure to use a version of gcc >=3.2.3


Ok… I thought this could be a problem. Upgrading gcc is not an option so I guess I will have to stick with an older version of root. I looked to see if there were any requirements for gcc and found none (possible… err probably I did not look in the right place). It looks as though gcc 2.9x is supported from the configure --help step of the install…

linux                for Linux gcc 2.9x, gcc 3.x and glibc

I guess I could install a local version of gcc… But man, that sounds complicated…