Root breakdown after Mac upgrade!

Dear All,
I think this is a known issue but I couldn’t find a real solution, actually I allowed my Mac for upgrade but I was surprised to find out that after finishing its upgrade my root is broken. I tried to recover it but I couldn’t so I started from scratch and try to reinstall it, but after finishing installing root, if I run root I got this:

dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Expected in: /usr/local/lib/libJPEG.dylib
 in /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO

does someone know why it’s doing this please, here are the commands I run to install root:

cd /opt
mkdir root
cd root
sudo mv ~/Downloads/root_v6.10.08.source.tar.gz .
sudo tar -zxvf root_v6.10.08.source.tar.gz
sudo mkdir root-6.10.08_build
sudo mkdir root-6.10.08_install
cd root-6.10.08_build/
sudo cmake /opt/root/root-6.10.08 -DCMAKE_INTALL_PREFIX=/opt/root/root-6.10.08_install/
make install

Thanks in advance,

Dear All,
Finally I found the solution by running these commands:

$ cd /usr/local/lib
$ rm libjpeg.dylib
$ ln -s /System/Library/Frameworks/ImageIO.framework/Resources/libJPEG.dylib libJPEG.dylib
$ rm libtiff.dylib
$ ln -s /System/Library/Frameworks/ImageIO.framework/Resources/libTIFF.dylib libTIFF.dylib
$ rm libpng.dylib
$ ln -s /System/Library/Frameworks/ImageIO.framework/Resources/libPng.dylib libPng.dylib

I found the solution in this website:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.