Root *** Break *** Segmentation Violation error

Hi, I’m working with some data in root running a .C file to produce a few simple plots. When I run the file it starts to access the input files then says there is a *** Break *** segmentation violation and the process crashes. It then lists the following (and note that root says that #5-13 may hint at the cause of the crash):

#0 0x00007fe83932410c in waitpid () from /lib64/
#1 0x00007fe8392a1de2 in do_system () from /lib64/
#2 0x00007fe839e4eef2 in TUnixSystem::StackTrace() () from /usr/lib64/root/
#3 0x00007fe839e5186c in TUnixSystem::DispatchSignals(ESignals) () from /usr/lib64/root/
#5 0x00007fe839625f68 in main_arena () from /lib64/
#6 0x00007fe82b59e02d in ROOT::Internal::TTreeReaderValueBase::ProxyRead() () from /usr/lib64/root/
#7 0x00007fe82b59e7c9 in ROOT::Internal::TTreeReaderValueBase::GetAddress() () from /usr/lib64/root/
#8 0x00007fe83a5a61e3 in ?? ()
#9 0x000000000265a1d0 in ?? ()
#10 0x00007fe839dbd450 in TCollection::~TCollection() () from /usr/lib64/root/
#11 0x00007fe839dc0558 in THashList::Delete(char const*) () from /usr/lib64/root/
#12 0x00000000008fdcc0 in ?? ()
#13 0x0000000000000000 in ?? ()

To give some detailed I attached the .C file that can be opened with a text editor.

Any ideas why this would happen and what I could do to fix it?
Thank you very much.

Readbackup_muons.C (2.4 KB)

ROOT Version (e.g. 6.12/06):
Platform: Ubuntu 18.04 LTS

Solved it, realized I had a few bracket misplacements.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.