ROOT and FTools setup problems


I installed the FTools for NASA’s Fermi mission, which use ROOT (or a limited install thereof) as part of the package, however, I cannot even plot a simple TF1, when I do I get the following error:

root [0] TF1 f1("f1","x",0,10)
root [1] f1.Draw()

dlopen error: cannot open shared object file: No such file or directory
Load Error: Failed to load Dynamic link library /home/chudson/glast/ScienceTools-v9r15p2-fssc-20090716-i686-pc-linux-gnu-libc2.5/i686-pc-linux-gnu-libc2.5/lib/
Error in <TGHScrollBar::TGHScrollBar>: arrow_*.xpm not found
Error in <TGVScrollBar::TGVScrollBar>: arrow_*.xpm not found

I’ve also tried a fresh install of ROOT over this, but I have no luck still. I have no idea how to set up the environment variables to reconcile the FTools with ROOT’s new install.


Which version are you using?
Did you install yourself from source?
In case you use a version generated by the Fermi support team, could you check with them?


I’m using ROOT 5.20, installed from source in Ubuntu on a x86 machine with GCC 4,3 (which is from the Fermi tools)

I’ve also downloaded ROOT 5.24, however my environment variables seem to point to the Fermi version, as the old version runs in preference.


Did the problem go away once you set the environment variable to the correct version of ROOT?


These problems have gone away now, thankfully

However, I haven’t tried using any of the Fermi tools yet