ROOT 6 XCode Version 7.3 fatal error


These days I updated my Xcode to the 7.3 version.

Since then when I run ROOT I constantly get the error:

fatal error: file
modified since it was first processed
Error in TClingCallFunc::make_wrapper: Failed to compile
==== SOURCE BEGIN ====
#pragma clang diagnostic push
#pragma clang diagnostic ignored "-Wformat-security"
attribute((used)) extern “C” void __cf_0(void* obj, int nargs, void** args, void* ret)
if (ret) {
((TGQuartz**)ret) = new TGQuartz((const char**)args[0], (const char*)args[1]);
else {
new TGQuartz(*(const char**)args[0], (const char*)args[1]);
#pragma clang diagnostic pop
==== SOURCE END ====
Error in TClingCallFunc::ExecT: Called with no wrapper, not implemented!

*** Break *** segmentation violation
Generating stack trace…
atos[15518]: [fatal] ‘pid_for_task’ failed: (os/kern) failure (5)[/code]

Can anyone help?
My root is on version v6-06-00 and I installed it via homebrew in my OSX10.11.4

Hi Carolina,

I’m getting the same error now, so I wanted to add my experience. This happens any time I cause a segfault now. The stack trace does not work.

For example, cause a trivial segfault:

I get the result:

*** Break *** segmentation violation Generating stack trace... atos[5547]: [fatal] 'pid_for_task' failed: (os/kern) failure (5)

This is on Mac OS 10.11.4 El Capitan with XCode 7.3 and ROOT 6.06/02.


I also have such problem.

I tried all the method:

[ul]cmake + make
cmake + Xcode build
./configure macosx64 …
brew install root6[/ul]

and all failed.

[code]root [0] TBrowser a
(TBrowser &) Name: Browser Title: ROOT Object Browser
root [1] TCanvas *c
(TCanvas *) nullptr
root [2] c->GetName()

*** Break *** segmentation violation
Generating stack trace…
atos[24853]: [fatal] ‘pid_for_task’ failed: (os/kern) failure (5)[/code]

Did you run at least once Xcode application and accept the license or other Apple requirement?

Hi mato, thanks for the suggestion, but yes, I have accepted the license for Xcode via command line, but this problem still exists.


This is a known problem; since a recent MacOS X update it requires special settings (see DevtoolsSecurity) to allow the ROOT backtrace functionality, or sudo powers.

A few weeks back I have provided a fix in the master by reimplementing ROOT’s backtrace functionality for MacOS. This will be part of 6.08 to be released later this year.

Cheers, Axel.