Home | News | Documentation | Download

Root 6 installation via macports (Error cannot load library/symbol not found)

Hi, I tried installing root6 on my Macbook (macOS High Sierra 10.13.6) throug macport via

sudo port install root6 and the installation seems to work fine but when I try to run root in my shell by simply typing

root

I get the following error message:
Fatal in <TROOT::InitInterpreter>: cannot load library dlopen(/opt/local/libexec/root6/lib/root/libCling.so, 5): Symbol not found: __ZN8TMemFileC1EPKcRKNS_14ZeroCopyView_tE Referenced from: /opt/local/libexec/root6/lib/root/libCling.so Expected in: flat namespace in /opt/local/libexec/root6/lib/root/libCling.so

What is the problem and how can it be fixed?

Anyone?

Hi,
sorry it’s the weekend, not many people around :slight_smile:

The macports ROOT package is not supported by the ROOT team, and the official support channel is “Trac Tickets”: https://ports.macports.org/port/root6/tickets , you should find the macports devs there.

Hope this helps,
Enrico

Hi thanks for the reply!
Could you please elaborate? I am really new to macports. I just tried using it because it was said that the root installation would be easy. What are the tickets about? What are the devs?

Ticket <–> bug/issue report
Devs <–> developers, or perhaps I should have said “maintainers” in this case – the people responsible for the ROOT macport

If macports do not work for you and you are not married to them, you can try using homebrew instead (also not officially supported by the ROOT team, but the maintainer hangs around in this forum). With homebrew installed, getting ROOT should be as easy as brew install root (might work better than macports in your case).

Cheers,
Enrico

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.