Root 6.26.10 build failure Mac OSX

Hello,

I need some help. I have been trying to build root from source (I have tried several different releases), finally trying the latest version.

I am running Mac OS Monterey 12.6.1, cmake version 3.25.0 and the latest command line tools for Xcode 14.

This is the command that I am running:

cmake -DCMAKE_INSTALL_PREFIX=. ../root-6.26.10-src -DPYTHON_EXECUTABLE=/usr/local/bin/python3 -DPYTHON_INCLUDE=/Library/Frameworks/Python.framework/Versions/3.11/include/python3.11 -DPYTHON_LIBRARY=/Library/Frameworks/Python.framework/Versions/3.11/lib/libpython3.11.dylib -DCMAKE_CXX_STANDARD=14

cmake --build . --target install

The configure step seems to proceed normally but the build, for multiple versions, keeps failing at building PCRE with the same error.

CMake Error at /Code/ROOT/root-6.26.10/builtins/pcre/PCRE-prefix/src/PCRE-stamp/PCRE-build-.cmake:49 (message):
  Command failed: 1

   '/Applications/CMake.app/Contents/bin/cmake' '--build' '/Code/ROOT/root-6.26.10/builtins/pcre/PCRE-prefix/src/PCRE-build' '--config' '' '--target' 'pcre'

  See also

    /Code/ROOT/root-6.26.10/builtins/pcre/PCRE-prefix/src/PCRE-stamp/PCRE-build-*.log

And the error log file has:

CMake Error: Invalid value used with --config

I don’t understand how to fix this error or get past it. Any help would be appreciated.

Please read tips for efficient and successful posting and posting code

_ROOT Version:6.26.10
_Platform:MacOSX 12.6.1
Compiler: Not Provided


Hi @megooden,

Building ROOT from source is discouraged, unless otherwise justified by a specific feature that is not part of the binary releases.
You may install a binary distribution of ROOT following the instructions here or using a Conda package.

That said, if you still want to go ahead building ROOT from source, see below.

It seems that the value for the option --config is missing in the formatted command line. You could try adding the -DCMAKE_BUILD_TYPE=Release option to the CMake command, as in:

$ cmake -DCMAKE_BUILD_TYPE=Release # ...

Cheers,
J.

Thanks for the help, using that option worked to get past the PCRE issue I was having.

The build failed due to an issue with Python 3.11 and not finding code.h in one of the files. I found this issue here from last week Fail to include "code.h" again v6.26/{08,10} again, so I will probably downgrade to another version of python.

I have never used the prebuilt binaries and always built root from source. I cannot find a page that lists what options are turned on for the binaries or if they are built for a specific version of python to utilize pyroot. I have tried to install the binary pkg and pyroot doesn’t seem to work so I have some more work to do to use it or try to build from source again.

For reference, this is what I get on a ROOT installation via Conda:

$ root-config --features
cxx17 asimage builtin_cling builtin_openui5 builtin_veccore clad dataframe
davix exceptions fftw3 fitsio gdml gviz http imt mathmore mlp minuit2
opengl pyroot pythia8 roofit webgui root7 rpath runtime_cxxmodules shared
soversion sqlite ssl tmva tmva-cpu tmva-pymva spectrum vc vdt veccore x11
xml xrootd

If you are not enabling any particular features and just using PyROOT, the installation via Conda should be fairly straightforward and quite probably fits your needs. You could also try to give it a try - see here.

Cheers,
J.