Root 6.26.06 make error

Hi experts,
I got the following error when I was building ROOT.

In file included from ROOT/build_6.26.06/net/netxng/G__NetxNG.cxx:38:
ROOT/root_source_git/net/netxng/inc/TNetXNGFile.h:27:10: fatal error: XrdCl/XrdClFileSystem.hh: No such file or directory
   27 | #include <XrdCl/XrdClFileSystem.hh>
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~

What package(s) that I missed ?

ROOT Version: 6.26.06
Platform: WSL2 (ubuntu 22.04)
Compiler: Not Provided

sudo apt install libxrootd-client-dev

cmake give the follwing:

 Found Xrootd version num: 5.4.1 (setting -DROOTXRDVERS=500040001)
              libXrdMain not found: xproofd will be a wrapper around xrootd
              libXrdClient not found: use built-in
              include_dirs: /usr/include/xrootd;ROOT/root_source_git/proof/xrdinc
              libraries: /usr/lib/x86_64-linux-gnu/

the installed xrootd-related packages in the system are libxrootd-dev, xrootd-server, libxrootd-client-dev


worked. Thank you.

now another problem. my python is in conda environment, when I run import ROOT in jupyter-lab, the python kernel just crashed.
I guest it was due to the absence of cppyy in the conda environment

You need to build ROOT using the same compiler (and libraries) that your “conda environment” uses.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.