ROOT 6.26/00 segmentation violation

ROOT Version: 6.26/00
Platform: WSL for windows 10 (ubuntu 20.04)
Compiler: cmake

When I try to install ROOT from source code with cmake it gives segmentation violation at 98%.
This only occurs with version 6.26/00 while 6.24/06 works fine.
Here i report the latest lines from the terminal:

[ 98%] Built target GenVector
[ 98%] Generating ../ginclude/rootCommandLineOptionsHelp.h
Scanning dependencies of target root
[ 98%] Building CXX object rootx/CMakeFiles/root.dir/src/rootx.cxx.o
[ 98%] Building CXX object rootx/CMakeFiles/root.dir/src/rootxx.cxx.o
[ 98%] Building C object rootx/CMakeFiles/root.dir/__/core/clib/src/strlcpy.c.o
[ 98%] Linking CXX executable ../bin/root
[ 98%] Built target root
Scanning dependencies of target modules_idx
[ 98%] Generating lib/modules.idx

 *** Break *** segmentation violation
 Generating stack trace...
Segmentation fault
make[2]: *** [CMakeFiles/modules_idx.dir/build.make:169: lib/modules.idx] Error 139
make[1]: *** [CMakeFiles/Makefile2:8953: CMakeFiles/modules_idx.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

Do you really need to build from source? Why don’t you take a binary distribution?

Even with the binary distribution i get the same error (segmentation violation)

~$ root

 *** Break *** segmentation violation
 Generating stack trace...

Hi Grufoony,

Have you tried calling the installation directory as “root” and not as “.root”?
(using the binary distribution)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.