ROOT 6.24/06 can not work on macOS Monterey

Please read tips for efficient and successful posting and posting code

ROOT Version: 6.24/06
Platform: macOS 12
Compiler: Not Provided

Dear ROOT experts,

I have updated my macOS to macOS 12. The ROOT was installed by Conda on my MacBook. After I activate my Conda environment, the ROOT can’t be opened successfully as usual. The log is in the attachment. Is ROOT incompatible with macOS Monterey? Or do I need to reinstall the ROOT?

Best regards,

runRoot.txt (5.1 KB)

1 Like

AFAIK, we don’t provide binaries for MacOS 12 yet. Maybe @Axel can give more details about our plans for the latest MacOS

Hi @zzl0024 ,
does uninstalling and reinstalling (either with conda or homebrew) help? If not, it’s likely that the problems will be fixed in the coming days, as macOS Monterey was released yesterday.


I see this too, even after reinstalling both with conda and with homebrew. I suspected it came from the upgrade of Xcode from 13 to 13.1, so I uninstalled Xcode 13.1 and installed the command line tools for Xcode 13 from the Apple developer site: Sign In - Apple and then brew and conda roots were working.


Many thanks! I tried reinstalling with conda and with brew several times yesterday, but it didn’t work. I also uninstalled Xcode CLT and tried installing Xcode CLT 12.5.1. It seemed like the Xcode CLT 12.5.1 can’t be installed on macOS Monterey. So I gave up.

…and xcode-select --install followed by a fresh installation via homebrew or conda does not help either, I guess?

@Axel do you have any other idea?

xcode-select --install will install Xcode CLT 13.1. If you try to run ROOT based on Xcode CLT 13.1, you will see those errors in my attachment.

That’s true, but you can install the dmg for the command line tools for Xcode 13 from Apple:

See Problem with root on macos: error: module 'Darwin' uses additional module map - #4 by Axel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.