Root 6.22.06 install on M1 Mac

Hi there,

I’m trying to install root 6.22.06 (latest stable) on M1 MacBook Pro. tried either from the source or Github with instructions. I’m getting a consistent error with OpenSSL.

[ 26%] Performing patch step (custom command) for 'OPENSSL'
patch: **** Can't find file '<' : No such file or directory
CMake Error at /Users/xiaobinlu/Downloads/software_tools/cmake/share/cmake-3.20/Modules/ExternalProject/captured_process_setup.cmake:29 (message):
Call Stack (most recent call first):
  /Users/xiaobinlu/Downloads/software_tools/cmake/share/cmake-3.20/Modules/ExternalProject/captured_process_setup.cmake:53 (_ep_message_quiet_capture)
  OPENSSL-prefix/tmp/OPENSSL-patch.cmake:16 (_ep_command_check_result)

make[2]: *** [builtins/openssl/OPENSSL-prefix/src/OPENSSL-stamp/OPENSSL-patch] Error 1
[ 26%] Copying header /Users/xiaobinlu/Downloads/software_tools/source/root/roofit/roofitcore/inc/RooSegmentedIntegrator1D.h to /Users/xiaobinlu/Downloads/software_tools/root/include
make[1]: *** [builtins/openssl/CMakeFiles/OPENSSL.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

also searched the forum posts like this

xcode-select --install is installed on Big Sur stable 11.2.1 (20D74)

any help is appreciated.

Please read tips for efficient and successful posting and posting code

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Hi @Jeremy_Lu ,
that’s a weeird compilation message (Can't find file '<' : No such file or directory), I am not sure what might be causing it.

However if you don’t have a particular reason for compiling ROOT from source yourself, you can install it on Big Sur via conda, Homebrew or Macports, see .


I actually went ahead and installed it with Mambaforge as mentioned in one of the threads. it worked out very easily. as for that error, I have no clue what’s causing that. thanks for the reply.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.