ROOT 6.22.02 build error XrdClient/XrdClient.hh: No such file or directory

Hello dear users,
I need to install ROOT as a prerequisite for GATE (geant4 application for tomographic emission). I downloaded the source files v6.22.02 and I have already installed all the prerequisites for ROOT.

I tried to install the binaries files but I got the error in GATE and that is why I am trying to install source files.

  • CMake Error at CMakeLists.txt:134 (MESSAGE):
    ROOT has been compiled with cxx_std_14, please use cxx_std_17 as your

I create folders build and installation. Inside the build folder, I insert the following command.

cmake -DCMAKE_INSTALL_PERFIX=/home/nano/Desktop/root-6.22.02/root-install /home/nano/Desktop/root-6.22.02/ -DCMAKE_CXX_STANDARD=17

and after, make -j2.
I got the following error and I am stuck in this. Does anyone knows how to help me?

Scanning dependencies of target RootAuth
[ 81%] Building CXX object net/auth/CMakeFiles/RootAuth.dir/src/TAuthenticate.cxx.o
[ 81%] Building CXX object io/sql/CMakeFiles/SQLIO.dir/src/TKeySQL.cxx.o
[ 81%] Building CXX object net/auth/CMakeFiles/RootAuth.dir/src/THostAuth.cxx.o
[ 81%] Building CXX object io/sql/CMakeFiles/SQLIO.dir/src/TSQLClassInfo.cxx.o
[ 81%] Building CXX object net/auth/CMakeFiles/RootAuth.dir/src/TRootAuth.cxx.o
[ 81%] Building CXX object io/sql/CMakeFiles/SQLIO.dir/src/TSQLFile.cxx.o
[ 81%] Building CXX object net/auth/CMakeFiles/RootAuth.dir/src/TRootSecContext.cxx.o
[ 81%] Linking CXX shared library …/…/lib/
[ 81%] Built target RootAuth
Scanning dependencies of target Netx
[ 81%] Building CXX object net/netx/CMakeFiles/Netx.dir/src/TXNetFile.cxx.o
/home/nano/Desktop/root-6.22.02/net/netx/src/TXNetFile.cxx:58:10: fatal error: XrdClient/XrdClient.hh: No such file or directory
58 | #include <XrdClient/XrdClient.hh>
| ^~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [net/netx/CMakeFiles/Netx.dir/build.make:63: net/netx/CMakeFiles/Netx.dir/src/TXNetFile.cxx.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:23792: net/netx/CMakeFiles/Netx.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
[ 81%] Building CXX object io/sql/CMakeFiles/SQLIO.dir/src/TSQLObjectData.cxx.o
[ 81%] Building CXX object io/sql/CMakeFiles/SQLIO.dir/src/TSQLStructure.cxx.o
[ 81%] Linking CXX shared library …/…/lib/
[ 81%] Built target SQLIO
make: *** [Makefile:152: all] Error 2

Welcome to the ROOT Forum!
You can either try to use a more recent version of ROOT, or disable Xrootd. Searching the forum could help, see for example When install root 6.22.08, can not find XrdClient.hh

Dear bellenot, thanks for your reply!
I was able to install root correctly. After the make -j2 command it works.
Now I got another error and I could not find in the forum.
After the make install, i got this

[100%] Built target ROOTPythonizations3_8
[100%] Built target JupyROOT2_7
[100%] Built target JupyROOT3_8
[100%] Built target hist2workspace
Install the project…
– Install configuration: “Release”
– Installing: /usr/local/ui5/distribution/
CMake Error at cmake_install.cmake:41 (file):
file INSTALL cannot make directory “/usr/local/ui5/distribution/”: No such
file or directory.

make: *** [Makefile:129: install] Error 1

Do you know how to solve it? thanks for your help!

I don’t know. But it looks like a problem with ui5 that might have been resolved in more recent version of ROOT. Maybe @linev remembers


You have to specify CMAKE_INSTALL_PREFIX to directory where you have write access. Like:

cmake -DCMAKE_INSTALL_PREFIX=/home/user/root/install -DCMAKE_CXX_VERSION=17 ... <your_root_source_dir>


Hi Sergey,
I entered the command

cmake -DCMAKE_INSTALL_PERFIX=/home/nano/Desktop/root-6.22.02/root-install /home/nano/Desktop/root-6.22.02/ -DCMAKE_CXX_STANDARD=17 -Dxrootd=OFF

Do you mean that I need to enter this? I did not understand. I`m sorry, I am new to root.

cmake -DCMAKE_INSTALL_PERFIX=/home/nano/Desktop/root-6.22.02/root-install -DCMAKE_CXX_STANDARD=17 -Dxrootd=OFF /home/nano/Desktop/root-6.22.02/


Hi Nicollas,

Yes, something like this.

By default install command tries to copy files in the default directories like /usr/lib64, /usr/bin and so on. Without super user rights you cannot do this - and I also do not recommend to install some debugging version of ROOT in default directories.

In principle, for debugging purposes you can use ROOT build directory without installing it.
Just call source <path_to_build>/bin/ and thats it.


Hi Sergey,

In my laboratory PC i have the user rights and I tried the suggestion that you recommended but I did not get success.

Inside root folder I create build and install directory. Inside build, I entered the command

cmake -DCMAKE_INSTALL_PERFIX=/home/nano/Desktop/root-6.22.02/root-install -DCMAKE_CXX_STANDARD=17 -Dxrootd=OFF /home/nano/Desktop/root-6.22.02/

– The C compiler identification is GNU 9.4.0
– The CXX compiler identification is GNU 9.4.0
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Detecting C compile features
– Detecting C compile features - done
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Detecting CXX compile features
– Detecting CXX compile features - done
– Found Git: /usr/bin/git (found version “2.25.1”)
– Looking for Python
– Could NOT find Python3 (missing: Python3_NumPy_INCLUDE_DIRS NumPy) (found version “3.8.10”)
– Could NOT find Python2 (missing: Python2_NumPy_INCLUDE_DIRS NumPy) (found version “2.7.18”)
– ROOT default compression algorithm: zlib
– PyROOT will be built for versions 3.8.10 (Main) and 2.7.18
– Found GCC. Major version 9, minor version 4
– Looking for pthread.h
– Looking for pthread.h - found
– Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
– Looking for pthread_create in pthreads
– Looking for pthread_create in pthreads - not found
– Looking for pthread_create in pthread
– Looking for pthread_create in pthread - found
– Found Threads: TRUE
– Found a 64bit system
– Found GNU compiler collection
– Performing Test GLIBCXX_USE_CXX11_ABI
– Performing Test GLIBCXX_USE_CXX11_ABI - Success
– ROOT Platform: linux
– ROOT Architecture: linuxx8664gcc
– Build Type: Release (flags = ‘-O3 -DNDEBUG’)
– Compiler Flags: -O3 -DNDEBUG -std=c++17 -Wno-implicit-fallthrough -Wno-noexcept-type -pipe -Wshadow -Wall -W -Woverloaded-virtual -fsigned-char -pthread
– Looking for ZLib
– Found ZLIB: /usr/lib/x86_64-linux-gnu/ (found version “1.2.11”)
– Looking for Freetype
– Found Freetype: /usr/lib/x86_64-linux-gnu/ (found version “2.10.1”)
– Looking for PCRE
– Found PCRE: /usr/include (found version “8.39”)
– Looking for LZMA
– Looking for lzma_auto_decoder in /usr/lib/x86_64-linux-gnu/
– Looking for lzma_auto_decoder in /usr/lib/x86_64-linux-gnu/ - found
– Looking for lzma_easy_encoder in /usr/lib/x86_64-linux-gnu/
– Looking for lzma_easy_encoder in /usr/lib/x86_64-linux-gnu/ - found
– Looking for lzma_lzma_preset in /usr/lib/x86_64-linux-gnu/
– Looking for lzma_lzma_preset in /usr/lib/x86_64-linux-gnu/ - found
– Found LibLZMA: /usr/lib/x86_64-linux-gnu/ (found version “5.2.4”)
– Looking for ZSTD
– Found ZSTD: /usr/lib/x86_64-linux-gnu/
– Looking for xxHash
– Could NOT find xxHash (missing: xxHash_LIBRARY xxHash_INCLUDE_DIR)
– xxHash not found. Switching on builtin_xxhash option
– Looking for LZ4
– Could NOT find LZ4 (missing: LZ4_LIBRARY LZ4_INCLUDE_DIR)
– LZ4 not found. Switching on builtin_lz4 option
– Looking for X11
– Found X11: /usr/include
– Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/
– Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/ - found
– Looking for gethostbyname
– Looking for gethostbyname - found
– Looking for connect
– Looking for connect - found
– Looking for remove
– Looking for remove - found
– Looking for shmat
– Looking for shmat - found
– Looking for IceConnectionNumber in ICE
– Looking for IceConnectionNumber in ICE - found
– X11_INCLUDE_DIR: /usr/include
– X11_LIBRARIES: /usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/
– X11_Xpm_INCLUDE_PATH: /usr/include
– X11_Xpm_LIB: /usr/lib/x86_64-linux-gnu/
– X11_Xft_INCLUDE_PATH: /usr/include
– X11_Xft_LIB: /usr/lib/x86_64-linux-gnu/
– X11_Xext_INCLUDE_PATH: /usr/include
– X11_Xext_LIB: /usr/lib/x86_64-linux-gnu/
– Found GIF: /usr/lib/x86_64-linux-gnu/ (found version “5.1.9”)
– Found TIFF: /usr/lib/x86_64-linux-gnu/ (found version “4.1.0”)
– Found PNG: /usr/lib/x86_64-linux-gnu/ (found version “1.6.37”)
– Found JPEG: /usr/lib/x86_64-linux-gnu/ (found version “80”)
– Looking for AfterImage
– AfterImage not found. Switching on builtin_afterimage option
– Building AfterImage library included in ROOT itself
– Looking for GSL
– Found PkgConfig: /usr/bin/pkg-config (found version “0.29.1”)
– Found GSL: /usr/include (found suitable version “2.5”, minimum required is “1.10”)
– Looking for OpenGL
– Found OpenGL: /usr/lib/x86_64-linux-gnu/
– Looking for GLEW
– Found GLEW: /usr/include (found version “2.1.0”)
– Looking for gl2ps
– Found gl2ps: /usr/lib/x86_64-linux-gnu/
– Looking for LibXml2
– Found LibXml2: /usr/lib/x86_64-linux-gnu/ (found version “2.9.10”)
– Found OpenSSL: /usr/lib/x86_64-linux-gnu/ (found version “1.1.1f”)
– Looking for MySQL
– Found MySQL: /usr/include/mysql
– Looking for Oracle
– Oracle not found.
– Oracle: You can specify includes: -DORACLE_PATH_INCLUDES=/usr/include/oracle/
– currently found includes:
– Oracle: You can specify libs: -DORACLE_PATH_LIB=/usr/lib/oracle/
– Oracle not found. Switching off oracle option
– Looking for PostgreSQL
– Found PostgreSQL: /usr/lib/x86_64-linux-gnu/ (found version “12.15 (Ubuntu 12.15-0ubuntu0.20.04.1)”)
– Looking for SQLite
– Found Sqlite: /usr/include
– Looking for Pythia6
– Pythia6 not found. Switching off pythia6 option
– Looking for Pythia8
– Could NOT find Pythia8 (missing: PYTHIA8_INCLUDE_DIR PYTHIA8_LIBRARY)
– Pythia8 not found. Switching off pythia8 option
– Looking for FFTW3
– Found fftw3 includes at /usr/include
– Found fftw3 library at /usr/lib/x86_64-linux-gnu/
– Looking for CFITSIO
– Found CFITSIO: /usr/lib/x86_64-linux-gnu/ (found version “3.47”)
– GFAL library not found. Set variable GFAL_DIR to point to your gfal installation
and the variable SRM_IFCE_DIR to the srm_ifce installation
– For the time being switching OFF ‘gfal’ option
– Found FTGL: /usr/include
– Checking for module ‘davix>=0.6.4’
– No package ‘davix’ found
– Looking for uuid_generate_random in uuid
– Looking for uuid_generate_random in uuid - found
– Found libuuid: /usr/include
– Davix dependencies not found, switching OFF ‘davix’ option.
– Looking for TBB
– Found TBB: /usr (found suitable version “2020.1”, minimum required is “2018”)
– Looking for VDT
– Found Vdt: /usr/local/include (found suitable version “0.4”, minimum required is “0.4”)
– Cannot select cudnn without selecting cuda or tmva-gpu. Option is ignored
– Looking for BLAS for optional parts of TMVA
– Looking for sgemm_
– Looking for sgemm_ - not found
– Looking for sgemm_
– Looking for sgemm_ - found
– Found BLAS: /usr/lib/x86_64-linux-gnu/
– TMVA: Numpy or Python development package not found for python /usr/bin/python3.8. Switching off tmva-pymva option
– Building LLVM in ‘Release’ mode.
– The ASM compiler identification is GNU
– Found assembler: /usr/bin/cc
– Looking for backtrace
– Looking for backtrace - found
– backtrace facility detected in default set of libraries
– Found Backtrace: /usr/include
– Native target architecture is X86
– Threads disabled.
– Doxygen disabled.
– Go bindings disabled.
– LLVM host triple: x86_64-unknown-linux-gnu
– LLVM default target triple: x86_64-unknown-linux-gnu
– Building with -fPIC
– Found PythonInterp: /usr/bin/python3.8 (found version “3.8.10”)
– Constructing LLVMBuild project information
– Linker detection: GNU ld
– SysLibs: rt;dl;tinfo;-lpthread;/usr/lib/x86_64-linux-gnu/
– Targeting X86
– Targeting NVPTX
– Clang version: 5.0.0
– Cling version (from VERSION file): ROOT_0.7~dev
– Cling will look for C++ headers in ‘/usr/include/c++/9:/usr/include/x86_64-linux-gnu/c++/9:/usr/include/c++/9/backward’ at runtime.
– And then fallback to: ‘x86_64-linux-gnu-g+±9’
– Performing Test CXX_HAS_Wno_maybe_uninitialized
– Performing Test CXX_HAS_Wno_maybe_uninitialized - Success
– Performing Test __result
– Performing Test __result - Success
– Performing Test CXX_HAS_fno_rtti
– Performing Test CXX_HAS_fno_rtti - Success
– Performing Test C_HAS_Wno_strict_overflow
– Performing Test C_HAS_Wno_strict_overflow - Success
– Performing Test C_HAS_Wno_maybe_uninitialized
– Performing Test C_HAS_Wno_maybe_uninitialized - Success
– Performing Test C_HAS_Wno_parentheses_equality
– Performing Test C_HAS_Wno_parentheses_equality - Success
– Looking for m
– Looking for m - not found
– Performing Test found_setresuid
– Performing Test found_setresuid - Success
– Performing Test found_stdstringview
– Performing Test found_stdstringview - Success
– Performing Test found_stod_stringview
– Performing Test found_stod_stringview - Failed
– Performing Test found_opplusequal_stringview
– Performing Test found_opplusequal_stringview - Success
– Performing Test found_stdapply
– Performing Test found_stdapply - Success
– Performing Test found_stdinvoke
– Performing Test found_stdinvoke - Success
– Performing Test found_stdindexsequence
– Performing Test found_stdindexsequence - Success
– Performing Test found_attribute_always_inline
– Performing Test found_attribute_always_inline - Success
– Performing Test has_found_attribute_noinline
– Performing Test has_found_attribute_noinline - Success
Running /home/nano/Desktop/root-6.22.02/build/unix/
Making /home/nano/Desktop/root-6.22.02/root-build/ginclude/compiledata.h
– Enabled support for: asimage builtin_afterimage builtin_clang builtin_llvm builtin_lz4 builtin_xxhash clad dataframe exceptions fftw3 fitsio gdml http imt mathmore mlp mysql opengl pgsql pyroot roofit webgui root7 runtime_cxxmodules shared sqlite ssl tmva tmva-cpu spectrum vdt x11 xml
– Configuring done
– Generating done
– Build files have been written to: /home/nano/Desktop/root-6.22.02/root-build

After this, I entered the
cmake --build . – install -j2

but I got the same error during the compilation

Install the project…
– Install configuration: “Release”
– Installing: /usr/local/ui5/distribution/
CMake Error at cmake_install.cmake:41 (file):
file INSTALL cannot make directory “/usr/local/ui5/distribution/”: No such
file or directory.

make: *** [Makefile:129: install] Error 1

Sorry, here is typo. Should be:


Dear Sergey,
Thank you for helping me! I finally managed to install ROOT correctly.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.