ROOT 6.17.01 Error in <TUnixSystem::FindDynamicLibrary>: /usr/lib64/ does not exist

_ROOT Version: 6.17.01
_Platform: Ubuntu 18.04 LTS virtual machine


This is a problem I’ve been facing for months now I don’t know what else I should do. I am running a c++ analysis program that uses the root & fftw3. However when I try to use the program to analyze root data it spits out this error when I try to use fftw3,

Error in TUnixSystem::FindDynamicLibrary: /usr/lib64/ does not exist in /usr/local/root/lib:/usr/local/root/lib:/usr/local/root/bindings/pyroot:.:/usr/local/root/lib:/lib/x86_64-linux-gnu/tls/x86_64/x86_64:/lib/x86_64-linux-gnu/tls/x86_64:/lib/x86_64-linux-gnu/tls/x86_64:/lib/x86_64-linux-gnu/tls:/lib/x86_64-linux-gnu/x86_64/x86_64:/lib/x86_64-linux-gnu/x86_64:/lib/x86_64-linux-gnu/x86_64:/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnu/tls/x86_64/x86_64:/usr/lib/x86_64-linux-gnu/tls/x86_64:/usr/lib/x86_64-linux-gnu/tls/x86_64:/usr/lib/x86_64-linux-gnu/tls:/usr/lib/x86_64-linux-gnu/x86_64/x86_64:/usr/lib/x86_64-linux-gnu/x86_64:/usr/lib/x86_64-linux-gnu/x86_64:/usr/lib/x86_64-linux-gnu:/lib/tls/x86_64/x86_64:/lib/tls/x86_64:/lib/tls/x86_64:/lib/tls:/lib/x86_64/x86_64:/lib/x86_64:/lib/x86_64:/lib:/usr/lib/tls/x86_64/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls:/usr/lib/x86_64/x86_64:/usr/lib/x86_64:/usr/lib/x86_64:/usr/lib

When I check to see if ROOT has fftw3 with the command

$root-config --has-fft3

it returns yes.

I installed ROOT using this guide:

Is there something I am missing? What can I do?


sudo apt-get install libfftw3-dev

I already have libfftw3-dev installed and I still get the same error.

Can it be that you have the “i386” version installed instead of “amd64”?

If not, try:

sudo apt-get purge libfftw3-dev; sudo apt-get install libfftw3-dev

BTW. It should be “/usr/lib/x86_64-linux-gnu/”. How come your ROOT wants " /usr/lib64/"? It seems like you were using libraries / binaries coming from another operating system.

I have the amd64 version installed. Also I don’t know why ROOT wants “/usr/lib64/” could the problem be how I installed ROOT onto my virtual machine?

Wherever you got ROOT from had ROOT built against /usr/lib64/ - while you don’t have that. I.e. there’s a mismatch in ROOT binaries vs your platform.

You could simply grab a binary for Ubuntu 18.04, either released or nightlies;O=D

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.