Root 6.10 on mac os sierra (10.12)

Hey guys,

I am trying to install the latest root on my mac os sierra. However over multiple attempts, I been running into this error when building it.

[ 75%] Generating tutorials/hsimple.root

Processing hsimple.C...
Error in <TApplication::ExecuteFile>: macro hsimple.C not found in path /tmva/test
make[2]: *** [tutorials/hsimple.root] Error 1
make[1]: *** [CMakeFiles/hsimple.dir/all] Error 2
make: *** [all] Error 2

It has been this simple.root that been giving problem each time I try to build it.

Any idea how I may overcome this?

Hi, it looks like your source directory is dirty (hsimple.root is a build product, it’s not part of the source, and it’s definitely not a tutorial :slight_smile: ). Could it be that you compiled ROOT straight from the source directory? That is not supported, you have to build ROOT from a separate build directory.

First off you could try to clean up your source directory:

cd $ROOTSYS # $ROOTSYS means "wherever your ROOT sources are"
git clean -fd
git checkout -f v6-10-00

And then re-build from scratch from a separate directory:

mkdir ~/ROOT_build
cd ~/ROOT_build
cmake --build . -- -j4

Let us know how that works out. If it still does not work, please post the output of git status when launched from ROOT’s source directory.

Thank you for the reply, I got my source from the official root webpage. I downloaded the 6.10.00 pro.

I am going to try again using git this time. will post again if it does not work.

Processing hsimple.C...
Error in <TApplication::ExecuteFile>: macro hsimple.C not found in path /tmva/test
make[2]: *** [tutorials/hsimple.root] Error 1
make[1]: *** [CMakeFiles/hsimple.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

hmm, I am getting the same error.

If you actually downloaded the git repo, followed the setup instructions for an out-of-source build and compiled ROOT in under ten minutes, that is pretty impressive both for you and your laptop :stuck_out_tongue:

If that’s the case I am not sure I can help, but as a first step please post the outputs of git status and find . | grep hsimple when launched from the ROOT source directory.

$ git status
On branch v6-10-00
Untracked files:
  (use "git add <file>..." to include in what will be committed)


nothing added to commit but untracked files present (use "git add" to track)
$ find . | grep hsimple

I think it may has to something to with how mac os x works? cause I am actually have problem running examples for tmva using root6.8 on my mac os.

I been learning how to tmva using root6.8 but have been running into problem so I though i do fresh install of a updated root to see if I can overcome it.

First things first, let’s get you a root installation up and running.

As per my first post, please remove the build-root directory from the root source directory and build ROOT again in a directory outside of the sources. Once you have successfully compiled ROOT this way (detailed instructions are available here) run source your/build/directory/bin/ and then root to check you have a working environment.

If it fits your needs, you can also try to download a pre-compiled binary for your platform from here. In that case you can skip compilation and directly try source-ing and running root.

So I managed to get it work via the binary distribution for my system. I could launch root with it.

For some reason I face the error as before when I build from source during make --build . -- -j4 stage.

Thanks for the quick reply.

Glad you made it work. I’ll mark this as solved. Don’t hesitate to open a new thread in case of further problems.

As a side note, ROOT is tested extensively on macOS 10.12 and a few ROOT developers actually use it as their operating system, so I believe a clean install following all instructions step by step should definitely work, unless something is wrong with your specific environment.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.