Root 6.04.00 looking for symbol ISDC_ENV when starting up


I have built root 6.04.00 on one of our Linux servers running SLF 6.4 (64bit). When I run the root executable I get the following errors

Error in TSystem::ExpandFileName: input: $ISDC_ENV/lib/libCling, output: $ISDC_ENV/lib/libCling

| Welcome to ROOT 6.04/00 |
| © 1995-2014, The ROOT Team |
| Built for linuxx8664gcc |
| From tag v6-04-00, 2 June 2015 |

Try ‘.help’, ‘.demo’, ‘.license’, ‘.credits’, ‘.quit’/’.q’

Error in TSystem::ExpandFileName: input: $ISDC_ENV/lib/libMathCore, output: $ISDC_ENV/lib/libMathCore

I think the symbol ISDC_ENV was part of the old astroroot package from the University of Geneva (which I used way back when root did not have FITS support) - you would assign ISDC_ENV to point to ROOTSYS. As far as I can tell I do not have this symbol defined anywhere in my environment but something in root thinks it should be looking there. I don’t know if this error is fatal but anyway it is annoying. Does anyone have any clues about why it might be doing this and how to make it go away?

Thanks very much

 Liz Buckley-Geer

How did you build ROOT? Can you tell us the configure command or the CMake command? I am sure $ISDC_ENV will come from there.

Here is my configure command



Hi. I have no idea from where this ISDC_ENV can come from. It is nowhere in ROOT itself. Can you for example do

to see the value of ROOTLIBDIR.

Solved it. After some poking around in my home area I noticed that I had a .rootrc file lying around from 2009 which contains

<> cat .rootrc

Path used by dynamic loader to find shared libraries

Unix.*.Root.DynamicPath: .:$ISDC_ENV/lib:$(ROOTSYS)/lib

left over from when I was using the astroroot package to get FITS support. I remove the reference to ISDC_ENV and now the error has gone away.

Thanks Liz