ROOT 5.30 - Ubuntu 11.10 - QT support

I recently upgraded to Ubuntu 11.10 and experienced problems installing ROOT. The forum gave some answers how to configure and compile, which worked fine, but I am also in need for the QT support for an online displays. This is what I did:

./configure --enable-roofit --enable-minuit2 --enable-builtin-freetype --enable-qt
make -j2 -k LDFLAGS=“-Wl,–no-as-needed”

It builds ROOT just fine including the library needed for the QT implementation. So I cleaned and tried to compile my QT program:

make distclean
make clean

I am now getting the following error:

/home/philip/bin/root/lib/ undefined reference to TRint::TRint(char const*, int*, char**, void*, int, bool)' /home/philip/bin/root/lib/ undefined reference to TCanvas::TCanvas(char const*, int, int, int)’
/home/philip/bin/root/lib/ undefined reference to `TImage::Create()’

Does anybody have an idea what is going wrong?

Thanks a lot,

I just installed ROOT 5.32 and this problem appears to be fixed.