ROOT 5.27.06 failed installation on Mac OS X 10.5.8


I tried compiling root 5.27.06 on my mac laptop (64-bit Intel core 2 duo) which is running Mac OS X 10.5.8. I followed the online instruction for a location independent installation (I have installed Xcode already). The libraries mostly compile, but the compilations seem to fail here (also note, I have also tried to explicitly disable rpath, with the same result):

gfortran -O2 -m64 -o bin/g2root main/src/g2root.o
-Llib lib/
/usr/local/lib/gcc/i686-apple-darwin8/4.2.3/…/…/…/x86_64/libgfortran.dylib /usr/local/lib/gcc/i686-apple-darwin8/4.2.3/x86_64/libgfortranbegin.a -lm -Wl,-rpath,@loader_path/…/lib -pthread -ldl
ld: -rpath can only be used when targeting Mac OS X 10.5 or later
collect2: ld returned 1 exit status
make: *** [bin/g2root] Error 1

Does anyone know what the problem might be, and how I can fix it?

Please use the latest version of gfortran, see:

Cheers, Fons.

Yes, thanks! I updated my gfortran (which I thought I had already done).

However, root still failed to compile with the new gfortran, now failing here:

g++ -c -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -m64 -D_REENTRANT -D_GNU_SOURCE -Wall -D__macos__ -Wno-deprecated -O2 -DXrdDEBUG=0 -DHAVE_STRLCPY -DHAVE_LIBZ -I. -I… -o …/…/obj/XrdOucUtils.o
make[5]: *** No rule to make target XrdOucFactoryBonjour.hh', needed by…/…/obj/XrdOucBonjour.o’. Stop.
make[4]: *** [Darwinall] Error 2
make[3]: *** [all] Error 2
make[2]: *** [XrdOuc] Error 2
make[1]: *** [all] Error 2
*** Error condition reported by make (rc = 2):
make: *** [net/xrootd/src/xrootd/LastBuild.d] Error 1
rm core/utils/src/RStl_tmp.cxx core/utils/src/rootcint_tmp.cxx

Do you have any ideas why its still crashing?

This is fixed in the ROOT trunk. Can you try?

Cheers, Fons.

Hi Fons,

I checked out the trunk.

  1. first I did ./configure and make, and the compilation failed with the gfortran error again (the same original error, but I have already downloaded the gfortran-4.2.3 dmg suggested on the ROOT installation page and installed gfortran).

  2. so next i did a make clean, and then did ./configure macosx64 --disable-rpath, and then did make. This second time it failed with the second problem (i.e. the problem: make[5]: *** No rule to make target XrdOucFactoryBonjour.hh', needed by…/…/obj/XrdOucBonjour.o’. Stop.)

So I am not sure if I have done something incorrectly, but it seems that I still have this problem with the trunk. Do you know what is causing the problem?

Thank you very much for all of your help!


Unfortunately we do not have the possibility to reproduce the problem.
The output of Xrootd-configure can provide some hint: please do

$ make distclean-xrootd
$ make all-xrootd > xrootd-configure.log

and post ‘xrootd-configure.log’.


Hi Gerri,

OK, I ran the lines of code you suggested and attached the xrootd-configure file.

Thank you for your continued help
xrootd-configure.txt (95.1 KB)


Thanks for the log.

Uhmm … there is no error in it and the build worked fine during that run.
So now if you do just ‘make’ it should be ok, at least it should pass the xrootd step.

So, it looks like something is not set correctly for a fresh build.


Hi Gerri,

Thanks for the help. I tried to do a ‘make’ and it failed again.

I am currently at CERN, perhaps I could email you and we could set up a time that I could come by and we could try to troubleshoot?