ROOT 5.20 on Suse 11.0 64bit

Hi there,

I’m trying to install ROOT 5.20 on a 64bit Suse11.0-machine. (gcc v 4.3-39.1)
Since I didn’t know which arch-flag to choose, I used the followig configure-command:

./configure --enable-opengl --with-opengl-incdir=/usr/include/ --with-opengl-libdir=/usr/lib64/

after typing “make”, ROOT compiles for a while until it stoppes with the following lines:

I tried typing “make” once more, which caused the following output:

So what do I need to do to get ROOT installed on my system? Can this be done anyway?



The first error message indicates an internal compiler error; our test with gcc version 4.3.1 were fine, but gcc 4.3 seems to be still somewhat unstable, so may be there are other issues.

By googling I found this

which applies to gcc 4.4 : it may be that Suse 4.3-39.1 includes this “regression” fix, but I could not check that.

If you do not need xrootd, I suggest that you disable it by adding


to your configure options.

Otherwise you should submit a bug report to the Suse guys and see what they say.

Gerri Ganis

PS: the second error is a consequence of the first one

it works without xrootd.

thanks a lot.


Dear ROOTers

I have just installed openSUSE 11.0 (32bit) on my MacBook Pro using VMware Fusion 1.1.3,
and downloaded/installed all available updates.

Then I tried to compile root_v5.20.00 and received the following error:

Creating shared library ../../lib/
g++ ../../obj/XrdCryptosslAux.o ../../obj/XrdCryptosslCipher.o ../../obj/XrdCryptosslFactory.o ../../obj/XrdCryptosslMsgDigest.o ../../obj/XrdCryptosslRSA.o ../../obj/XrdCryptosslX509.o ../../obj/XrdCryptosslX509Crl.o ../../obj/XrdCryptosslX509Req.o ../../obj/XrdCryptosslgsiAux.o ../../obj/XrdCryptosslgsiX509Chain.o -m32 -shared -lssl -lcrypto ../../lib/libXrdCrypto.a ../../lib/libXrdSut.a ../../lib/libXrdOuc.a -o ../../lib/
Make crypto done.
Making secpwd component...
cd src/XrdSecpwd;\
        make all ARCH=i386_linux --no-print-directory
g++ -c -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -m32 -D_ALL_SOURCE -D_REENTRANT -D_GNU_SOURCE -fPIC -rdynamic -Wall -Wno-deprecated -D__linux__  -O2 -DXrdDEBUG=0  -DUSENEWHDRS -I. -I.. -o ../../obj/XrdSecpwdSrvAdmin.o
Creating executable ../../bin/xrdpwdadmin
g++ -m32 -D_ALL_SOURCE -D_REENTRANT -D_GNU_SOURCE -fPIC -rdynamic -Wall -Wno-deprecated -D__linux__  -O2 ../../obj/XrdSecpwdSrvAdmin.o -lcrypt  -L../../lib -lXrdCrypto -lXrdSut -lXrdOuc -lXrdSys -lnsl -lpthread -lrt -ldl -lc -o ../../bin/xrdpwdadmin
                -o ../../obj/XrdSecProtocolpwd.o In member function ‘virtual XrdSecCredentials* XrdSecProtocolpwd::getCredentials(XrdSecParameters*, XrdOucErrInfo*)’: internal compiler error: in copy_reference_ops_from_ref, at tree-ssa-sccvn.c:588
Please submit a full bug report,
with preprocessed source if appropriate.
See <> for instructions.
make[5]: *** [../../obj/XrdSecProtocolpwd.o] Error 1
make[4]: *** [Linuxall] Error 2
make[3]: *** [all] Error 2
make[2]: *** [XrdSecpwd] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/rabbitus/ROOT/root/net/xrootd/src/xrootd'
make: *** [net/xrootd/src/xrootd/lib/] Error 2
rm core/utils/src/RStl_tmp.cxx core/utils/src/rootcint_tmp.cxx

This is the same error as reported above for Suse 11.0 64 bit!
Thus I disabled xrootd and succeeded with the compilation.

However, I am not happy that I need to disable something since users of my R package will have
problems installing root.

Does anybody know the current status of the gcc compiler?

Here is my gcc version:

rabbitus@linux-yn1c:~/ROOT/root> gcc --version
gcc (SUSE Linux) 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Gerri mentioned above that he tested gcc version 4.3.1 and it worked fine,
but this seems not be the case. Which exact version did work fine?

Best regards

ROOT comnpiles without any problems with gcc4.3.1.
In your case you get a compiler error (not a compilation error).
likely a problem with your emulator on the MAC.


Dear Rene

Thank you, but could it be that this is an error especially of the compiler version used by openSUSE 11.0?

I do not think that this is an error of the emulator since the error message is completely IDENTICAL to the error message which Asim gets on his 64bit Suse11.0 machine, which does not use an emulator.

The problem is that the Bioconductor people have set up a new server using openSUSE 11.0 (64bit) and tell developers that their software must compile with gcc 4.3.1 on openSUSE for the next bioC release, see: … 01689.html

Best regards


It does indeed seems to a bug in the gcc version in suse (it is "4.3.1 2008/05/07 (prerelease) [gcc-4_3-branch revision 135036). You may want to have this problem reported to Suse.

In the meantime, you could try to disable xrootd and/or build in debug mode.


Dear Philippe

Thank you for your confirmation. I have already disabled xrootd.
I do not understand why SUSE does not supply the final version of gcc on their server.

Best regards