ROOT 5.04 running Ok, but

I have just installed ROOT 5.04 on my Fedora core 4 with no problems, but the following error message is given when I run root.:

[code]Error in TCint::LoadLibraryMap: library map empty, no system.rootmap file
found. ROOT not properly installed.

  •                                     *
  •    W E L C O M E  to  R O O T       *
  •                                     *
  • Version 5.04/00 20 September 2005 *
  •                                     *
  • You are welcome to visit our Web site *
  •            *
  •                                     *

FreeType Engine v2.1.9 used to render TrueType fonts.
Compiled on 19 October 2005 for linux with thread support.

CINT/ROOT C/C++ Interpreter version 5.16.2, July 14 2005
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.

However root seems to work properly :open_mouth: eventhouht the message explicitly says “ROOT not properly installed”.
What do you think?

You have installed ROOT from source and forgot to run
make map
make cintdlls



just a short question:
the link you gave does not explicitly mention the “(g)make map” command - is this automatically done by “make install” or is it necessary to do it explicitly - in which case it would probably be a good idea to include it in the documentation?

Read carefully the install page, in particular the section
"Choosing the installation method"


that’s exactly why i’m asking - the only place where a map is mentioned is this line:

this would indicate that it’s not necessary to run “make map”.


If you do “make install” it is not necessary to explicitly do “make map” since that is the first step done in “make install”.

Cheers, Fons.


I’m having a problem getting “make map” to work:

kordosky> make map
bin/rlibmap -r etc/system.rootmap -l lib/
-d -c auth/inc/LinkDefRoot.h
rlibmap: error locking output file
gmake: *** [map-auth] Error 1

This is with tag 5-06-00 on a cern scientific linux machine. My configuration is:

kordosky> root -config
ROOT ./configure options:
QTDIR=/usr/lib/qt-3.1 CERNLIB=/cern/pro/lib PYTHIA6=/unix/minos/software/pythia6/slc3_gcc323 linux --enable-mysql --with-mysql-incdir=/unix/minos/software/slc3_external/include/mysql --with-mysql-libdir=/unix/minos/software/slc3_external/lib/mysql --enable-dcache --with-dcap-incdir=/unix/minos/software/slc3_external/include --with-dcap-libdir=/unix/minos/software/slc3_external/lib --enable-qt --enable-cern --with-cern-libdir=/cern/pro/lib --enable-pythia6 --with-pythia6-libdir=/unix/minos/software/pythia6/slc3_gcc323 --enable-shared --enable-xml --enable-thread --enable-minuit2 --enable-mathcore --enable-mathmore --enable-reflex --enable-cintex --enable-roofit

I’ve tried deleting the file but when I run rlibmap again I get the same error. I have also used /sbin/fuser to make sure no other process is locking the output file.

Any ideas?

Turns out that this problem was nfs related. I was building on a nfs mounted partition. When I tried the build on the machine serving the nfs partition it worked.



I have the exact same problem, but am not at CERN etc.

So my problem is surely not NFS related.

The ‘make’ and ‘make cintdlls’ went fine on my Linux8664gcc system.

but when I execute: make install

I get this error message:

make[1]: Entering directory /apps/geant4/root5/root' bin/rlibmap -r etc/system.rootmap -l lib/ \ -d -c auth/inc/LinkDefRoot.h rlibmap: error locking output file make[1]: *** [map-auth] Error 1 make[1]: Leaving directory/apps/geant4/root5/root’
make: *** [install] Error 2

or if I try a ‘make map’ first:

g++ -m64 -O2 -o bin/rlibmap utils/src/rlibmap.o
bin/rlibmap -r etc/system.rootmap -l lib/
-d -c auth/inc/LinkDefRoot.h
rlibmap: error locking output file
make: *** [map-auth] Error 1

Any help would be highly appreciated!


Greets Joerg