I was performing a simultaneous fit running root from lxplus. I was checking root version 5.26 and everything was working fine. Since Friday my fits (same code, same ntuples, same ROOT setup) are failing.

Is there anything that changed in lxplus? Also, I tried to compile from scratch root in my laptop and I couldn’t get the simultaneous fit to work… Am I missing something?

Many thanks,


Did you change the ROOT version on lxplus ? This could explains the difference, although it is more likely that you have something else different. We can try to help you, but we need a running macro showing your problem


Hello Lorenzo!

Unfortunately is difficult to provide a macro because it needs the ntuples to run on etc…

I solved part of the problem! So now I have my script performing the sim fit perfectly.

The questions becomes:

why this script is not working on my mac? Is it something in the compilation that I’m not including?

In my mac I have

asimage astiff bonjour builtin_afterimage builtin_ftgl builtin_glew builtin_pcre builtin_lzma cintex exceptions explicitlink fftw3 fitsio gdml genvector krb5 ldap mathmore memstat minuit2 monalisa odbc opengl pgsql pythia6 pythia8 python reflex roofit ruby rpath shared ssl table tmva unuran x11 xft xml xrootd thread

in lxplus I see

asimage astiff builtin_afterimage builtin_ftgl builtin_freetype builtin_glew builtin_pcre builtin_zlib castor cint5 cintex editline dcache exceptions explicitlink fftw3 gviz gdml genvector gfal globus krb5 ldap mathmore memstat minuit2 mysql opengl oracle pythia8 python qt qtgsi reflex roofit rfio shadowpw shared ssl table tmva unuran xft xml xrootd thread

I tried to reproduce the configuration of lxplus in my mac, but no good result…

I don’t know. There could be many things. You should be more precise, in specifying what is different, the final result or if in one case it crashes or it does not compile. If it does what is the message ?
Are you running a compiled script or interpreted one ?
Are you sure you are using the same version of ROOT ? It could be in one machine you are using a different one you are thinking…


Hello Lorenzo and thanks for your reply!

I’m compiling my script. My script is not crushing or anything. I’m attaching the result from my computer (right) and from lxplus (left)… Same version of ROOT on both…

Many thanks again,


I think you are not using the same versions. When you start “root”, without option “-l” it prints the version. Is it the same ?


Hello Lorenzo!

My bad. Indeed with the same version of ROOT it works.

Sorry for causing to much pain, but can you please let me know what it may be the problem that causes it not to work with a newer version?