RooFit crashes in Jupyter notebook but not in script


I installed ROOT and jupyterlab together via conda. ROOT related things seems to be functional except when I try fitting with RooFit. This causes a crash. I don’t have the stack to show since notebooks suppress this output but the notebook hangs and I notice gdb is called. However, when running the same code as a standalone python script, things work perfectly.

I have attached a simple script to provide a minimal working example (which can be pasted as a notebook cell). I can’t upload a yml file here, but I am happy to make it available if needed.

Has this problem been noticed before? I have only started having this problem with newer versions of ROOT v6.22-6.24.


John (2.3 KB)

ROOT Version:v6.24.02

Hi @jcob,

I don’t have immediately at hand a ROOT build + Jupyter support, but will try to reproduce tomorrow. What I can say for the moment is that you could try splitting the code into different notebook cells so that we can try to delimit where the problem is.


I just made an identical environment on another machine and tested the minimal example in jupyterlab/notebook and it works.

I’m not sure what could cause something like this to happen for different machines

Hi @jcob,

I was not able to reproduce this locally. The only thing I can suggest is to run

$ root --notebook

from a terminal in the machine in which you see the failure. If execution is aborted, you might be able to see a stack trace on stderr that you could attach here.


Hi @jalopezg,

I tried running with root --notebook but I get the same issue and no stack trace was produced. I’ll try rolling back to root v6.24


Maybe @etejedor or @jonas could also suggest something here?

I can’t reproduce the error, I tried on SWAN with LCG 100 (ROOT 6.24) and also in my machine with JupyterLab and ROOT master, both work fine.

There must be something in the environment that is different in the failing machine? For example, some other ROOT installation that is interfering with the conda one?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.