"R__unzip (zlib)" error

Dear all,

I am trying to run a compiled subroutine (.L -----.C+) I successfully used a year ago. I didn’t make any modification to the code or to the ROOT files required. Unfortunately, I have now an error and I do not understand what it means:

Here this is the print out in the terminal

Treating Brho = 1015 R__unzip: error -3 in inflate (zlib) File : b1015light.root

And the corresponding piece of codes:

cout << " Treating Brho = " << Brho[i] << endl; ostringstream data_file ; data_file << "b" << Brho[i] << "light.root"; TFile *root_file = TFile::Open(data_file.str().c_str()); TTree *Tree_Data = (TTree*)root_file->Get(root_file->GetListOfKeys()->At(0)->GetName()); cout << " File : " << data_file.str() << endl;

The code ends with a segmentation violation a bit further (when I start to use the data contained in the tree). As I guess it a problem at the opening of the files.

So I tried to check the contain of the files with a TBrowser. For some of the Branches, I have a huge amount of error messages:

Error in <TBasket::ReadBasketBuffers>: fNbytes = 7648, fKeylen = 81, fObjlen = 11692, noutot = 0, nout=0, nin=7567, nbuf=11692 R__unzip: error -5 in inflate (zlib)or

R__unzip: error -3 in inflate (zlib) Error in <TBasket::ReadBasketBuffers>: fNbytes = 7666, fKeylen = 80, fObjlen = 11692, noutot = 0, nout=0, nin=7586, nbuf=11692 Error in <TBasket::Streamer>: The value of fObjlen is incorrect (-552376725) ; trying to recover by setting it to zero Error in <TBasket::Streamer>: The value of fNbytes is incorrect (-1782155502) ; trying to recover by setting it to zero terminate called after throwing an instance of 'std::bad_alloc' what(): std::bad_alloc

I tried with different ROOT files and the results is the same. I tried on different computers (Ubuntu 10.04 with ROOT 5.30 and Linux Mint Debian Edition with ROOT 5.32). Last time I used this code without any problem it was under Ubuntu 9.04 and ROOT 5.26/5.28.

If someone has a hint about what happens and at which level I have to investigate, thank you very much in advance.


The source of the problem seems to be the hard drive itself: there is some problem with the power supply. I checked of the hard drive with fsck and it crashed. So I’m now recovering my files from lost+found.