QtRoot -layer Qt 3.x based support to be phased out

Hello Rooters.
STAR core software group is going to phase out :exclamation: the support of the Qt 3.x-based implementation of QtRoot layer.
It is our intention to provide Qt 4.3.x and higher based version only starting from the next ROOT production release.
Qt 3.3.x code will remain in our CVS repository. However the new features will be provided for Qt 4.3.x based version only.

Is there any objection?

Please, let us know as soon as possible to accommodate your needs if any.
Please forward your options and ideas via lists.bnl.gov/mailman/listinfo/qt-root-l or send it to me directly
"fine at bnl dot gov"

Dear Valeri,

What an excellent news! (this should be posted on root.bnl.gov as well :smiley: )
I (and I’m sure with me many others) really appreciate and thank you and the STAR team for this interface. Looking forward to Qt4 support!

thanks,
mauri

Hello mauri

[quote=“ungaro”]What an excellent news! (this should be posted on root.bnl.gov as well :smiley: ) [/quote] It was :wink: announced 4 months ago
indico.cern.ch/materialDisplay.p … nfId=13356 “QtRoot project status and examples of its use at STAR” slide 29

Mmmm :blush: May be I did no express the idea clear enough. Qt 4.3.x-based QtRoot and its support are ALREADY provided. To see how it works define QTDIR to point to the Qt 4.3.x (Qt 4.3.x is the very version the Qt-layer was tested against of) installation directory and re-run either ROOT configure or “qmake”. The port is still in its “beta” stage. Your feedback is welcome.
See: ftp://root.cern.ch/root/doc/26ROOTandQt.pdf
"Qt Package Installation and Configuration" and
"Qt-layer Installation" also

What I’ve been discussing is the phasing out the Qt 3.x support.

Hi Valeri,

the reason I’m not up-to-date is that I periodically look at the QTROOT page root.bnl.gov/ .
Maybe I missed the announcement, but the QT version mentioned there is still 3.3.7 (as of 04/16/2007). Am I looking at the wrong page?

Anyway, I will test it and provide feedback soon.

thanks again!
mauri

Hello Mauri , [quote=“ungaro”]the reason I’m not up-to-date is that I periodically look at the QTROOT page root.bnl.gov/ .
[/quote]Thank you very much for your comment.
I’ll adjust the front page in question to make it more clear and less confusing.[quote=“ungaro”]Maybe I missed the announcement, but the QT version mentioned there is still 3.3.7 (as of 04/16/2007).[/quote]As soon as Qt 4.x is concern we did announce the move during ROOT 2007 Workshop ( indico.cern.ch/materialDisplay.p … nfId=13356

[quote=“ungaro”]Am I looking at the wrong page?
[/quote]The Qt version you have mentioned is the version included into the last available binary for Windows. It is not the Qt version the QtRoot can be built against of. It is my intention to prepare the Windows binary with
ROOT 5.16 + Qt 4.3.x + Coin3D 2.4.6. ( coin3d.org ) shortly.
Since it is the first time I do the Qt 4.3.x related Windows binary I need some extra time to test things

[quote=“ungaro”]Anyway, I will test it and provide feedback soon.
[/quote]Many thanks. May I ask you to provide me the ROOT benchmarks (run “benchmarks.C” macro, please) with Qt-layer on/off to see the layers performance?