PyROOT vs graphics on a mac


I’m trying to install ROOT on mac OSX 10.5.8, and running into some problems. I initially tried configuring without arguments ("./configure"), and some things worked by pyROOT didn’t. Another RootTalk thread suggested adding the “macosx” architecture, and I also had to disable xrootd, giving me “./configure macosx --disable-xrootd”. With this, pyROOT works, but the graphics don’t:

[code]root [0] new TBrowser
dlopen error: dlopen(/Users/mjf/ROOT_53006/root/lib/, 9): Symbol not found: _alphablend_scanlines
Referenced from: /Users/mjf/ROOT_53006/root/lib/
Expected in: dynamic lookup

Load Error: Failed to load Dynamic link library /Users/mjf/ROOT_53006/root/lib/
Error in TCint::AutoLoad: failure loading library for class TASImage
Error in TPluginHandler::SetupCallEnv: class TASImage not found in plugin ASImage
Error in TGVSplitter::TGVSplitter: splitterv.xpm not found
Error in TGHSplitter::TGHSplitter: splitterh.xpm not found
Error in TGComboBox::TGComboBox: arrow_down.xpm not found
Error in TGVScrollBar::TGVScrollBar: arrow_*.xpm not found[/code]

Looking around, I found a thread with a similar problem (Prob after installing root on mac), but no real solution, as I always installed it in my user area as you can see from the above trace. I’ve also tried adding --enable-builtin-afterimage to the config command, but with no joy.

Are there any other suggestions for things I could try? I’ve already cleaned and made this again three or four times from scratch.

Mike F

Hi Mike,

I recommend that you submit PyROOT related issue direcly the ROOT/PyROOT forum.



it’s a linking problem with, nothing to do with PyROOT per se. If you look at the traceback, you can see that Mike is attempting to start a TBrowsers from the root.exe prompt and then runs into a missing symbol problem.


Hi Mike,

With ‘macosx’ on the configure line you request the 32 bit build. That PyROOT works with it but not without means that there is an issue with python 64bit (or lack there of). That libASImage does not work with macosx means that there is a missing 32 bit library is somewhat odd.

Did you try with ROOT v5.32 and/or the trunk?



ROOT 5.32.01 seems to work, thanks! So far, I’ve tested canvasses and histograms with CINT and the python command lines, and a python histogram-plotting script. All worked without errors. For the record, this is my configure command:
./configure macosx --disable-xrootd --enable-builtin-afterimage

I did try to build under macosx64 (with 5.30), but I don’t appear to have 64 bit python, so this isn’t a solution for me.