Home | News | Documentation | Download

Problems with ROOT after a system update

Hello,

I’ve encounter an issue while coding that has prevented me from compiling any of my code. I think my computer may have run an update over night since when I started to run my code one morning, it just stopped working.

My computer no longer seems to be able to compile my code using the ROOT libraries. Instead, I am getting errors that say that there are undeclared identifiers in the libraries like as well as others.

I have tried re-downloading and updating ROOT using Anaconda but nothing so far has worked.

I’m not sure if anyone else is also having similar issues following the most recent Mac update, but I’m not sure what I did to cause all the code that was working the night before to suddenly stop compiling the next morning.

Any help would be appreciated.

ROOT Version: 6.24/00
Platform: MacOS Big Sur 11.3
Compiler: Clang


Hi @RichCap123,

It might be that the CommandLineTools package was updated recently and the compiler is getting a wrong header search path. I think there are similar posts in the forum, e.g. ROOT 6.10/08 on macOS High Sierra compiling macro example.

If none of the issues already solved in the forum helps, you could try manually executing the compiler command line (first line after the make invocation in the second screenshot), and add -v to see the underlying cc1 command. The -I... arguments should give a hint on what is wrong/missing. If needs be, you can copy the cc1 command line here.

Cheers,
J.

@jalopezg I looked into RichCap123 problem. I also suspect the problem is the CommandLine Tools, which were recently updated on Big Sur, but I am not sure what one can do about this. I looked at the post you linked and it seems what fixed those problems was a new version of root.

Hi @RichCap123,

It seems that the headers in the anaconda environment, i.e. .../anaconda3/envs/my_root_env/include/c++/, are conflicting with those provided by the toolchain. @eguiraud, have you faced this before?

Cheers,
J.

Uhm it might help to also use cmake and g++/clang++ from the conda environment.
Unfortunately I have little experience with Mac, maybe @chrisburr can also help :slight_smile: