Problems with ROOT 6.06/02 on El Captain (mac OSX 10.11.4)

Hello everyone,

I am running El Captain (mac OSX 10.11.4) on a new MacBook Pro and I simply went to and downloaded … lang70.dmg

I find series of problems when just trying to use the binary.
I illustrate them below.
Any help would be greatly appreciated.
Should I try to build ROOT from scratch?
It seems strange as binaries worked fine for me with previous 10.9.5 (I never downloaded this version there though…).


I proceeded to the installation and then I followed the instructions

for my main directory I sourced the this root file
source /Applications/root_v6.06.02/bin/
(I also put out in my .profile)

After that I tried start root and I got the following:

-----> START <------
pb-d-128-141-232-141:~ francescospano$ root
input_line_1:1:10: fatal error: file ‘/Library/Developer/CommandLineTools/usr/bin/…/include/c++/v1/new’ modified since it was first processed
input_line_3:38:10: fatal error: file ‘/Library/Developer/CommandLineTools/usr/bin/…/include/c++/v1/string’ modified since it was first

| Welcome to ROOT 6.06/02 |
| © 1995-2014, The ROOT Team |
| Built for macosx64 |
| From heads/master@v6-07-02-437-gb06340c, Mar 02 2016, 19:01:57 |

Try ‘.help’, ‘.demo’, ‘.license’, ‘.credits’, ‘.quit’/’.q’

input_line_8:1:10: fatal error: file ‘/Library/Developer/CommandLineTools/usr/bin/…/include/c++/v1/iostream’ modified since it was first
root [0]

----------> END<---------------

In addition when I tried to open a TBrowser I got a crash: should Cling not already be part of ROOT?

----> START<-----
root [1] TBrowser hh
IncrementalExecutor::executeFunction: symbol ‘_ZN5cling7runtime6gClingE’ unresolved while linking function ‘_GLOBAL__sub_I_cling_module_7’!
You are probably missing the definition of cling::runtime::gCling
Maybe you need to load the corresponding shared library?

*** Break *** segmentation violation
Generating stack trace…
0x00000001023944f9 in cling::valuePrinterInternal::printTypeInternal(cling::Value const&) (in + 265
0x000000010239187d in cling::Value::print(llvm::raw_ostream&) const (in + 29
0x00000001023919fa in cling::Value::dump() const (in + 90
0x000000010237a265 in cling::runtime::internal::setValueNoAlloc(void*, void*, void*, char, void const*) (in + 101
0x0000000110bfc115 in
0x000000010236c10d in cling::Interpreter::RunFunction(clang::FunctionDecl const*, cling::Value*) (in + 317
0x000000010236b599 in cling::Interpreter::EvaluateInternal(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, cling::CompilationOptions, cling::Value*, cling::Transaction**) (in l
0x000000010236af64 in cling::Interpreter::process(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, cling::Value*, cling::Transaction**) (in + 100
0x00000001023a6e3f in cling::MetaProcessor::process(char const*, cling::Interpreter::CompilationResult&, cling::Value*) (in + 415
0x000000010228125a in TCling::ProcessLine(char const*, TInterpreter::EErrorCode*) (in + 3690
0x0000000101c1b213 in TRint::ProcessLineNr(char const*, char const*, int*) (in + 211
0x0000000101c1bd5f in TRint::HandleTermInput() (in + 671
0x0000000101dcdc38 in TUnixSystem::CheckDescriptors() (in + 328
0x0000000101dcaa5d in TMacOSXSystem::DispatchOneEvent(bool) (in + 429
0x0000000101d195ea in TSystem::InnerLoop() (in + 26
0x0000000101d1943b in TSystem::Run() (in + 203
0x0000000101cbce04 in TApplication::Run(bool) (in + 36
0x0000000101c1b0cc in TRint::Run(bool) (in + 1372
0x0000000101c11e8f in main (in root.exe) + 79
0x00007fff8b4135ad in start (in libdyld.dylib) + 1
0x0000000000000002 in
Root >

------> END<------

Hello Spano.

I’ll just stab in the dark a little.

  1. Have you installed Xcode ?, if not please do, then also install the “command line tools” by issuing the following command in a terminal session

then click agree to download and install when a window pop up

  1. I have always compiled ROOT using the source code on all Mac and Linux machines that I use. It is surprisingly simple, especially on the Mac. I fully recommend everyone to compile ROOT rather than install the binary. (I have just compiled ROOT 6.06/02 last night on the latest 10.11.4 + Xcode 7.3 without any problem).

Steps for compiling ROOT 6.06/02

  1. Download and unzip the archive just by simply double-click
  2. Open terminal and go to the directory where things are extracted to
  3. issue command

sudo ./configure macosx64 
sudo make

Once compilation is finished, there will be a file called inside the directory bin, inside the current folder. Issue this command before running ROOT

source bin/


I cannot reproduce this. I have upgraded XCode 7.3; downloaded … lang70.dmg - installed it and then

. /Applications/root_v6.06.02/bin/
root -l

I also tried to “.L” the code

void xcode() {
  ifstream res_data;

that has caused problems for one of our users - in vain, it just works for me.

Could you attach lldb to your invocation of ROOT:
lldb – root.exe

and then at lldb’s prompt:

b clang::TextDiagnosticPrinter::HandleDiagnostic

and send the output?

Cheers, Axel.

That said - the error message should contain “XCode” in the path, not “CommandLineTools”. Please install / upgrade XCode / run xcode-select --install.

Cheers, Axel.

Thanks all . I have been travelling. I will check the suggested solutions in the coming days and I will get back to you all.

hello Axel, useRoot,
the problem is solved, It was enough to install Xcode (I did not have it) .
I all works. Thanks!!!