Problems with most recent xcode on OSX 11.3 Xcode 12.5

I had a nice 6.24 install going in miniconda from conda-forge. Worked great. Then I updated xcode to 12.5 and now get errors like:

[ 1%] Building CXX object CMakeFiles/plotutils.dir/PlotUtils/AnaBinning.cxx.o
In file included from /Users/schellma/local/Ana/PlotUtils/PlotUtils/AnaBinning.cxx:4:
In file included from /Users/schellma/local/Ana/PlotUtils/PlotUtils/AnaBinning.h:4:
In file included from /Users/schellma/miniconda/envs/new_root_env/bin/…/include/c++/v1/vector:275:
In file included from /Users/schellma/miniconda/envs/new_root_env/bin/…/include/c++/v1/iosfwd:95:
/Users/schellma/miniconda/envs/new_root_env/bin/…/include/c++/v1/wchar.h:137:77: error: use of undeclared identifier ‘wcschr’
wchar_t* __libcpp_wcschr(const wchar_t* __s, wchar_t __c) {return (wchar_t*)wcschr(__s, __c);}

etc for many items you should find in std::

This is unfortunately in a complicated cmake environment and a simple compile with root doesn’t cause the issue so I’m still working on a simpler reproduction as a test case. But I’d be interested if other people have seen this problem and how they dealt with it. my 6.22 install outside of conda still works so I’ve reverted to that while I wait for xcode to settle down.

I was able to make (not very pretty) test.
testme.tar (70 KB)

to run the test untar the directory. cd testme; source; look at bad.log.

Works with root from the dmg download but not with conda-forge version. Probably some horrible problem with my setup but I see the web is full of people running into problems when xcode upgrades.

I have seen several topics on this forum related to issues after an OSX/Xcode update. Did you try to see if one of them could help solving your problem?

I tried the most obvious one, which is reinstalling the command line tools and it did not help. Most of the reported issues are with local builds. I’m using the conda-forge version. Probably my problem is that Xcode changed after the conda-forge version was built and I’ve gotten ahead of the latest valid version. Lesson learned is never update Xcode when your machine asks you to. Let it sit for a couple months. Why I did this I don’t know, as I’ve spent the last year talking people through OS/Xcode install recovery.

Hmm, noting that Axel submitted a change to cmake 3.19 that looked related. I’m using cmake 3.14. Might try an upgrade and see if he fixed the issue for the whole world.

No dice, cmake 3.20 didn’t fix it.

Do you expect your build system to pick up the standard library here:

In general that looks less of a ROOT and more of a Conda question. @eguiraud can you invite here whoever you believe can help? (Was there something along the lines of “and you need to make the matching compiler available”?)

do I understand correctly that this is the situation:

  • start from an environment with no ROOT → install ROOT with the dmg → you can compile your project that depends on ROOT
  • env with no ROOT → install ROOT via conda → you can’t compiler your project that depends on ROOT

and if that’s the case, can you try also using a toolchain (cmake + compiler) from the same conda environment?

@chrisburr might have more experience/ideas.


There was an issue with the macOS 11.3 SDK (see here for details).

I think it should have been fixed, though I’m not sure if the patch also needs to be backported to clang 9. Can you recreate your environment and test to see if it now works? If you still have issues can you post the output of conda list and conda info.

1 Like

I did a new conda install and the problem appears to be fixed. Thanks for your help on this. I will let the experts upgrade new Xcodes from now on.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.