Problems to install Root 5.26 on Mac OS X 10.6.7

Hi everyone,

I have a problem installing Root on my Mac. I started with a virgin Snowleopard, version 10.6.7. Due to other requests I need the Root version 5.26. I tried it with different patches and always end with the following error:

gfortran -O2 -m32 -o bin/g2root main/src/g2root.o
-Llib lib/
/usr/local/lib/gcc/i686-apple-darwin8/4.2.3/…/…/…/libgfortran.dylib /usr/local/lib/gcc/i686-apple-darwin8/4.2.3/libgfortranbegin.a -lm -Wl,-rpath,@loader_path/…/lib -pthread -ldl
ld: -rpath can only be used when targeting Mac OS X 10.5 or later
collect2: ld returned 1 exit status
make: *** [bin/g2root] Error 1

I configured with ./configure macosx. Any idea why I get this error?

Thanks a lot for the help!

Please install a more recent version of gfortran that works with 10.6.7 (the latest in Fink will do).

Cheers, Fons.

I updated my gfortran version and now get the following error message:

g++ -c -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -m32 -D_REENTRANT -D_GNU_SOURCE -Wall -D__macos__ -D__DARWIN_UNIX03=1 -Wno-deprecated -O2 -DXrdDEBUG=0 -DHAVE_STRLCPY -DHAVE_LIBZ -I. -I… -o …/…/obj/XrdOucUtils.o
make[5]: *** No rule to make target XrdOucFactoryBonjour.hh', needed by…/…/obj/XrdOucBonjour.o’. Stop.
make[4]: *** [Darwinall] Error 2
make[3]: *** [all] Error 2
make[2]: *** [XrdOuc] Error 2
make[1]: *** [all] Error 2
*** Error condition reported by make (rc = 2):
make: *** [net/xrootd/src/xrootd/LastBuild.d] Error 1


Please try:

make distclean-xrootd
make all-xrootd

Cheers, Fons.

Ok, now it’s compiling without error!

But when I run Root and try to
#include “Math/GSLIntegrator.h”

I get the following error:
dlopen error: dlopen(/usr/local/root//lib/, 9): Symbol not found: _gsl_interp_akima
Referenced from: /usr/local/root//lib/
Expected in: flat namespace
in /usr/local/root//lib/
Load Error: Failed to load Dynamic link library /usr/local/root//lib/
Error in TCint::AutoLoadCallback: failure loading library for class ROOT::Math::GSLIntegrator

Any idea?
Thanks a lot!

Looks like an old version of libGSL. Did you also update this lib?

Cheers, Fons.

I just installed the current GSL version (gsl 1-14).

Thanks, Francis