Problems running programs: No such file or directory

ROOT Version: 6.10/08
Platform: Ubuntu 18.04 LTS

Hi everyone,
I’m new to this forum and to ROOT in general, and I don’t know how to handle these things properly :sweat_smile:.
I’m a Physics student, and I usually use ROOT to do some fit tasks. It all worked well with my virtual machine Ubuntu 16.04, until I updated to Ubuntu 18.04. Now when I try to run a program (in this case named rlcvr) I get this error message:

rlcvr: error while loading shared libraries: cannot open shared object file: No such file or directory

I read an old thread where someone solved the problem modifying a file in the /etc/ directory, but when I open the /etc directory there’s no folder named
P.S. I used the binary file to install ROOT the first time.

Thank you,

All right, solution found: I messed up with directories and ended up in the wrong /etc/ folder. Once found he right on I was able to use suggestions in this topic: [Solved] cannot open shared object file: No such.
(I reply here because I don’t have the permission to delete this topic, even though it’s quite useless to others…)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.