Problems installing v5.12.00 on SL4


I am attempting to compile ROOT version 5.12.00 from source on scientific linux 4 (kernel 2.6.9-34.EL) with gcc version 3.4.4.

I used the following configure command:

./configure linux --prefix=/<afshome>/root_sl4 --libdir=/<afshome>/root_sl4/lib --etcdir=/<afshome>/root_sl4/etc --enable-soversion --enable-xrootd --enable-dcache --with-krb5=/usr/krb5

‘make’ yields after a while:

g++ -c -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_ALL_SOURCE -D_REENTRANT -D_GNU_SOURCE -fPIC -rdynamic -Wall -Wno-deprecated -D__linux__  -DXrdDEBUG=0 -I. -I.. -I/usr/krb5/include -o ../../obj/XrdSecProtocolkrb4.o In member function `virtual XrdSecCredentials* XrdSecProtocolkrb4::getCredentials(XrdSecParameters*, XrdOucErrInfo*)': error: `krb_mk_req' undeclared (first use this function) error: (Each undeclared identifier is reported only once for each function it appears in.) In member function `virtual int XrdSecProtocolkrb4::Authenticate(XrdSecCredentials*, XrdSecParameters**, XrdOucErrInfo*)': error: `krb_rd_req' undeclared (first use this function) In static member function `static int XrdSecProtocolkrb4::get_SIR(XrdOucErrInfo*, const char*, char*, char*, char*)': error: `krb_get_lrealm' undeclared (first use this function)
make[5]: *** [../../obj/XrdSecProtocolkrb4.o] Error 1
make[4]: *** [Linuxall] Error 2
make[3]: *** [all] Error 2
make[2]: *** [XrdSeckrb4] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/jforbes/root-install_5.12.00_3/xrootd/src/xrootd'
make: *** [xrootd/src/xrootd/lib/] Error 2
rm utils/src/RStl_tmp.cxx utils/src/rootcint_tmp.cxx

This compiles normally with the same configure script on scientific linux 3 with gcc 3.2.3

Any ideas?



Could you try the following:

In $(ROOTSYS)/xrootd/, line 154 change the line:

xopt="$$xopt --enable-echo --no-arch-subdirs --disable-mon"; \


xopt="$$xopt --disable-krb4 --enable-echo --no-arch-subdirs --disable-mon"; \

(add --disable-krb4 in xopt)
And tell us if it solves the problem, please.


Yes, that worked.

Thanks very much.