Problems in building software in docker ROOT container

Hi all,

I am investigating some issues in the CI pipeline we have for our software, which is based on ROOT. We have two pipelines, based on docker images:

  • The first uses the mambaforge conda image, installs the most recent ROOT via conda and then builds our software. This works fine.
  • the second uses the official ROOT docker image (rootproject/root:latest, i.e. 6.30.02) and builds directly the software

The latter recently started giving compilation errors when building our software. These below are the issues I found, that in the conda installation of ROOT I do not see:

  • the nlohmann JSON package is not available (solvable by running apt install -y nlohmann-json3-dev in the container)
  • the VDT library is not installed (solvable by installing it following the instruction at GitHub - dpiparo/vdt)
  • most strikingly, the compilation gives as error fatal error: Math/Polynomial.h: No such file or directory. I checked into the directory /opt/root/include/Math` and indeed the file is not there

I checked with ldconfig -p | grep gsl and the GSL library is there, but it seems that ROOT was not built with the mathmore option. If so, this I cannot solve myself, I tried to search for a solution but could not find one.

Do you have suggestions on how to proceed?


As complement to my previous message, indeed ROOT was built without mathmore in the container:

root@e26b8edc6d61:/opt/root/include/Math root-config --features
cxx17 asimage builtin_clang builtin_cling builtin_llvm builtin_openui5 builtin_vdt clad dataframe test_distrdf_pyspark test_distrdf_dask davix fitsio gdml http mlp minuit2 mysql opengl pgsql proof pyroot roofit webgui root7 rpath runtime_cxxmodules shared sqlite ssl tmva tmva-pymva spectrum vdt x11 xml xrootd

see related issues:

most have been solved in the meanwhile, so hopefully 6.30.04 will work.

Thanks @ferhue , my bad on not checking properly past posts… I will set this as completed and wait for the next release. Thank you for your help!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.