Home | News | Documentation | Download

Problems after ROOT installation/update


Please read tips for efficient and successful posting and posting code

ROOT Version: 6.22/02
Platform: Bash in Ubuntu on Windows (WLS, Windows 10, Ubuntu 16)
Compiler: 5.4.0


Hi.
Sorry for annoying you again. I think I have done something really wrong during the update of the bash to ubuntu 16 and of my old version of ROOT to the last. After these processes, my laptop started crashing with blue screens and SYSTEM_SERVICE_EXCEPTION errors (it reboots with this error when I try to start it after suspending the system) and ROOT stopped compiling/interpreting some of my codes with a temporary error “sh: 1: Syntax error: Unterminated quoted string” which disappears after some hours letting me compile all the codes after this time . Maybe somebody knows about a possible solution/problem?

I don’t know if this post is appropriate here (@Axel ) , if not you can delete it.

note: I have no programs on the laptop which were installed just before (less than 15 days) or after ROOT so I think I missed something during this installation/update

Hi,
do you have enough space on disk?
The blue screens are unrelated to ROOT. You mentioned that after a while the ROOT-related errors disappeared – seems all is good now?

Cheers,
Enrico

Hi.
I have more than 150 Gb on disk.
The ROOT related errors appear randomly every few days. Example: I compile two codes during the same hour. The first is compiled and executed by ROOT without problems, the second gives me the error “sh: 1: Syntax error: Unterminated quoted string” but after some hours if I try again to compile the second code it is compiled without problems. Then everything seems to return to normal but after a few days the same error reappears and disappears again after some hours. Same problem using Cling. I tried to find a solution with my teacher but we can’t explain this mysterious behaviour :sweat:.
Thanks for your helpfulness :relaxed:

That is really weird :sweat_smile: I have no idea what might cause it, sorry.

Don’t worry :relaxed:. My laptop can be really strange sometimes :sweat_smile:. This will stay on the forum so maybe if somebody has the same problem we can find something in common that can cause it

If the blue screen only happens when running Ubuntu, try removing Ubuntu and even WSL, and then resintalling. I haven’t used WSL2 and I’m not very sure, but I read somewhere that it changes some things, so I’d stick to WSL 1, which works well enough (not optimal, but it works). Also, make sure you get Ubuntu from the MS Store; I don’t even see Ubuntu 16 there, so I don’t know how you updated to it, and from which version!; anyway, unless you have no alternative, get the latest, .i.e. Ubuntu 20.04 LTS.
If the blue screens happen (only or also) when you are not even running Ubuntu, then it’s probably not related to it, and could be hardware issues (memory and/or hard drive, especially since you mention your laptop is like that), or file corruption on your Windows (even if you don’t install anything, Windows is always quietly installing ‘updates’ that sometimes can fail or break stuff).

Hi. Blue screens appear even when I don’t use Ubuntu. I will control accurately all the updates and the files that could have been corrupted if this could solve the problem.
I tried to install Ubuntu 20 on the bash (WSL1) but the bash crashed miserably during the installation and I had to adapt myself to Ubuntu 16 which updated automatically from my native Ubuntu 14 using “do-release-upgrade”. Thanks for your help

As I said, it’s probably better to install Ubuntu from the Microsoft Store application, not from inside WSL, but if you make it work, good :slight_smile:

Hi.
Blue screens solved with a system restore (a bit brutal…) . Still problems with ROOT even after updating the bash (I even tried a new version of Ubuntu without improvements so I came back to Ubuntu 16). Today I got the same error complemented by some strange lines about ACLIC. I hope somebody will recognize them as an error already seen on his computer because it makes ROOT unusable for longer times whenever it appears :weary:

Thanks in advance

Hi.
ROOT 6.22.02 definitely stopped working on my laptop (sh:1 errors duration was so long that they overlapped so I could no longer use it).
I have tried installing ROOT 6.08.02 on the same bash and it seems more collaborative (it compiles the old “troublesome codes” without crashing, at least up to today) and even the older version of ROOT I had earlier than a month ago (ROOT 3) worked without problems on the same bash.
Same sh:1 problem on the other hand with ROOT 6.20.02 on Ubuntu 16 and 18 (the error sh:1 appeared at the time of the first compiling, after Ubuntu installation, of a code which uses user defined classes (3 files: header+implementation+macro))
Maybe there are communication problems between the last ROOT releases and some “old” Bash in Ubuntu/Windows 10 releases? (I don’t want to criticize your work, I just want to report possible problems so that ROOT (or informations about its installation) could get better).
Thanks a lot :relaxed:

Hi,
we build the latest ROOT versions on Ubuntu 16 every night, it’s part of our testing infrastructure.
What error messages do you get exactly?

It would be great if you could provide a reproducer that we can test e.g. in a Ubuntu 16 docker container.

Cheers,
Enrico

Hi.
Surely ROOT works on Ubuntu 16/18/20 because some of the students I know use it. My doubts concern possible problems with some old Windows 10 builds on which we can create WLS subsystems, or with some WLS releases (I don’t know if ROOT can “communicate” through Ubuntu with the native operating system (Windows)).
I upload the code I used for these tests (a simple and quite horrible code :sweat_smile:) and the results I got from ROOT 6.22.02 and ROOT 6.08.02 both on Ubuntu 16 same bash

compilemyclass.C (223 Bytes) Myrandom3.h (294 Bytes) Myrandom3.cxx (533 Bytes) random.c (381 Bytes)

Thanks

Ah it’s still that "Unterminated quoted string" problem…really weird, I really have no clue, sorry :sweat:

I bet it’s because of the space in the user name (“Asus pc”). Can you move ROOT e.g. to C:\ROOT - does that fix it?

Hi. Thanks for your answer. If you mean creating the codes in a folder out of “Asus pc”, go there with the cd command and running ROOT there, I tried this (using the Users folder in C) but same problem; if you mean moving ROOT packets in a folder “out of everything” in C I must plead ignorance: I don’t know where they are in the hard disk (I can find them only in the bash with Ubuntu’s commands but in C and D I can’t find anything related to ROOT)

Sorry - indeed I should have talked about your code, not ROOT: please try to move your code (compilemyclass.C etc) e.g. into C:\code or wherever, then cd there and try again. Does that help?

I tried but same problem. When I try compiling the class it never works regardless of the directory ( the error is exactly the same, only with the strings “mnt/c/Users…” changed in “/mnt/c/root”). Today I made some experiments: some of my older codes compile only if before opening ROOT I delete the related C_ACLIC_dict_rdict.pcm (but not the .d and .so files) and I reboot the laptop, both out of "Asus pc " and inside it. But the same strategy doesn’t work with the class and with other codes. I am puzzled. I think I will give up the idea of using a “newer” ROOT version because this seems an impossible task.
Anyway, thanks :slightly_smiling_face:

Humm. We need to get this fixed nonetheless, even if not for you then for future Windows / WSL users. @bellenot can you reproduce the failure described here?

I’ll set-up a machine and try

1 Like

OK, so I had no problem with root_v6.22.02.Linux-ubuntu16-x86_64-gcc5.4.tar.gz installed in WSL 1, running Ubuntu 16.04 (xenial), on Windows version 10.0.16299.2166:

root [0] .x compilemyclass.C
Info in <TUnixSystem::ACLiC>: creating shared library /mnt/c/Users/sftnight/Downloads/Myrandom3_cxx.so
Info in <TUnixSystem::ACLiC>: creating shared library /mnt/c/Users/sftnight/Downloads/random_c.so
root [1] random(0.1)
standard
Info in <TCanvas::MakeDefCanvas>:  created default TCanvas with name c1
root [2]