Problems about loading comsol files

I want to import the mesh file solved by comsol, but encountered the following problems
This is my code

This is my model

I have tried to reinstall Garfield + +, but it still doesn 't work.
Can you give me some advice?

These are the files solved by comsol (1.1 MB)
mplist.txt (12 Bytes)
potential_CZT_anode0cathode-600.txt (1.8 MB)

Dear @zql21 ,

Maybe @hschindl can help you here.


I located the mistake here, but I still don 't know how to solve it

@djjansse could you take a look?

Dear @zql21,

Can it be that the mesh elements of the exported tetrahedral mesh are not second? Currently, the ComponentComsol class only accepts second order tetrahedral meshes.

Kind regards,


Thank you for your reply!
Could you tell me where to set the order of the tetrahedral meshes in comsol?
I don’t know the order of the tetrahedron meshes in my programme

the mesh setting of comsol is shown in the figure.

Dear @zql21,

You will find it under the settings of the physics interface (most likely the Electrostatic module in your case), called Discretization which should be on Quadratic. Then, for the exporting of the mesh and data, the Select resolution option should be set to Custom while Select Lagrange order ought to be on 2, as laid out in this Garfield++ example.

Kind regard,


The Discretization setting is originally on Quadratic.

I change the export setting,but still can’t load the mesh file.


Dear @zql21,

Interesting. Could you send me the newly exported files and code so I can take a closer look?

Kind regards,


Here are my codes and solution data (2.1 MB) (191.5 KB)
mplist.txt (13 Bytes) (735.2 KB)

I checked the code and found something that puzzled me.
The mesh file I exported contains ‘3 tet # type name’ ,

However, in is “4 tet2 # type name”

I don 't know the difference between ‘3 tet # type name’ and “4 tet2 # type name”
Run the code, get the following result

In addition, if I change ‘3 tet # type name’ to “4 tet2 # type name” in my mesh file.Then run the code,

I did a simple test and found that the bug seems to be happening here, but I don 't know how to fix it.

Dear @djjansse
Can you load mesh file correctly? Have you found what caused this bug?
Looking forward to your reply.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.