Problem with TIFF using TImage

Hello all,
Some people in my lab are thinking about using root for Image analysis. I made some preliminary tests under linux and it seems that it fits their needs, but when I tried to run it under Windows XP I had some trouble.
The command
TASImage *img = TASImage::Open(“110205_10.tif”);

ERROR: unable to load file “110205_10.tif” - missing TIFF image format libraries.

The script imgconv.Cin the tutorials directory returns me

root ERROR: unable to write file “rose512.tiff” - TIFF image format is not supported.

Can somebody tells me which library I must install ?

Thanks in advance.

yes, that is current limitation. ASImage library depends on libtiff which
is missing under windows. It can be downloaded from

I’ll try to investigate and find solution for this problem.
If you will succed with it, please, let me know.

Regards. Valeriy


I installed the libtiff package on my system (Windows XP) but I still get the error message “missing TIFF image format libraries”. Could someone give me a hint on that?



We will investigate and let you know.


More infos:
Actually, TIFF is not supported with libAfterImage on Windows. And there is no easy way to solve this issue.
Anyway, we will investigate and try to find a solution, but it will probably take some time.


Hi Bertrand,
I meant libtiff shipped with cygwin, did you try it?

Regards. Valeriy

Hi Valeriy,

The problem is the configuration step and the makefile on Windows, not libTIFF itself…
There is no problem at all installing libTIFF on Windows…


That is correct! The installation is working but Root still complains that libraries are missing.