Problem with the installation of ROOT- Unable to locate package libtinfo6

Hello! I’m trying to install ROOT in my system (Linux Mint 19.3 Cinnamon), but I have the same problem as chiara described in their post.

I tried installing both versions of ROOT (root_v6.22.02.Linux-ubuntu18-x86_64-gcc7.5.tar.gz AND root_v6.22.00.Linux-ubuntu19-x86_64-gcc9.2.tar.gz), but I still get the error message:

Fatal in TROOT::InitInterpreter: cannot load library cannot open shared object file: No such file or directory

I also tried installing the packages, but the error persists.

Maybe, the problem has to do with the installation of an incorrect version of ROOT, but I cannot find one suitable for Linux Mint 19.3.

Does anyone have any suggestions? Thank you in advance!

Hi @Aggelos_T

Did you try package for Ubuntu 20. But in general - if there is no binary package for your platform, you need to compile ROOT from source as described here


I downloaded this version, but while unziping it this error message comes up:

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

Any ideas?

Did you download full file?
That is result of sha256sum root_v6.22.02.Linux-ubuntu20-x86_64-gcc9.3.tar.gz for you?
Should be: b1d12816a6e551e8b91b27d5a89685fcb8bb157ab1f5c066b9d6a2acb4d86b33
How you unpack file?

For me it works - at least in batch mode.

I downloaded the package using the terminal and the following commands, following the instructions here.

tar -xzvf root_v6.22.02.Linux-ubuntu20-x86_64-gcc9.3.tar.gz

And that’s when the error appeared.

I also followed this method with the previous 2 packages I mentioned above, but didn’t encounter a problem while unzipping, only after using

source root/bin/

and trying to launch root by writing


in the terminal.

Can you compare checksum

I believe it’s the same: b1d12816a6e551e8b91b27d5a89685fcb8bb157ab1f5c066b9d6a2acb4d86b33.

For me same file works.
It has to do with unpacking on your file system.
Please check suggestions from google tar: Unexpected EOF in archive

Ok, so I deleted and re-downloaded root_v6.22.02.Linux-ubuntu20-x86_64-gcc9.3.tar.gz using the same method as before (wget, tar, source), but the first problem still persists when writing root in the terminal:

Fatal in TROOT::InitInterpreter: cannot load library cannot open shared object file: No such file or directory

Is there anything else I can do? Maybe another version I can try?
Thank you for your help so far.

No. You need to build ROOT from source

I already tried installing the Ubuntu 18 version, but I had the same problem. Now, I’m trying to install ROOT from the source, as @linev proposed, but I’m having a different problem, as I mention in this post.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.