Problem with TGStatusBar

So as I understand it, adapting my full software is not really straightforward. There is quite a lot of development to do, right?

yes, TG classes must be fully replaced

The change that cause it was quite recent (we noticed that Apple seriously changed all their rendering machine - graphical context when drawing views does not respect/has no clipping set). What we had to fix was (iirc) TGTextView related classes, but apparently either this change broke something less obvious or something else was not fixed (strange we don’t see it in other places :wink: ). What you see to me looks like the initial geometry for those ‘segments’ is incorrect/not set yet and they all drew their text in one place (after you resize they have better coordinates for their text (??). The way text is rendered is a bit controversial to start with, that’s why Apple keeps breaking our GUI :smiley: I will check the issue asap.

4 Likes

And by the way @Timur_Pocheptsov, Welcome to the ROOT forum ! :wink: :smiley:

1 Like

thanks Olivier, I had to fight a bit with a system trying to log in, but it’s much easier these days!

1 Like

I confirm that the problem/bug can be reproduced on macOS 14, but not on previous versions. I tried to reduce the UI’s complexity and at some point the bug seems to disappear (just to check what I mean, in ToggleTab - return immediately from this function), though resizing the tab widget’s frame brings the bug back. And I understand the resulting reduced UI is not what the original UI is and if it worked before, it should work now too, whatever UI is. I also agree with Bertrand - having a simpler reproducer would help a lot, as it is now - UI is very heavy on tabs and debugging this particular UI is quite time/resource consuming.

1 Like

Dear Timur,

Thanks a lot for your help. My free time is very limited nowadays but I will try to produce a simple reproducer as soon as possible.

I don’t know if you saw it but an easy fix is to add this line: fStatusBar->SetLayoutBroken(true); but I have no idea of the possible side effects of such a command…

Jérémie

Actually, I have found a very easy reproducer:
1 - Open a new TBrowser
2 - Open the Editor (View/Editor)

And this will do the same corrupted values in the TGStatusBar:

Here also, changing the canvas size fix the problem until we don’t click in the pad:

dear @Timur_Pocheptsov, did you had time to have a look in what is causing this same issue in the standard ROOT TBrowser when using the Editor ?

Jérémie

hi @dudouet , no, I did not have time to debug this yet (p.s. my apologies to Betrand - I’ve clicked your name accidentally in the list after typing ‘@’)