Home | News | Documentation | Download

Problem with root on Centos. error while loading shared libraries:libzstd.so.1

Hello everyone,
I’m new on this forum and I know little about Linux. When I install root on Centos8,I met some problems. I fellow the install step on the website of cern. When I finished the install, I tried to
run the root command. It began spitting “Fatal in TROOT::InitInterpreter: cannot load library libtinfo.so.5: cannot open shared object file: No such file or directory”.

At first, I thought it was the root version I installed that didn’t match the platform, and I installed Centos7.9 on the virtual machine, the same problem occured again.

what should I do now?

Hi @401zjf,

Welcome to the ROOT forum. It seems that you are missing some dependencies. You could try installing ncurses and zstd:

$ sudo yum install ncurses ncurses-devel libzstd libzstd-devel

Cheers,
J.

1 Like

hi J, thanks for your reply.
I’ve installed these dependencies, but there is another problem. bash: root: command not found…

.

After reading your previous post, it´s unclear to me whether you installed ROOT via the system package or a binary distribution.

Anyway, and assuming that a binary distribution was uncompressed in /home/zhoujiangfeng/Applications/root/, you should source thisroot.sh.

$ source /home/zhoujiangfeng/Applications/root/bin/thisroot.sh

To avoid having to do this every time, you can add that line to your .bashrc file. To that end:

$ echo 'source /home/zhoujiangfeng/Applications/root/bin/thisroot.sh' >> ~/.bashrc
1 Like

I installed root with these steps,

after finished that ,I ran these two lines

then ,I ran the root command, and the first problem occurred.

@401zjf Did you try the steps I suggested in my last post?

1 Like

I’ve tried your post,and it couldn’t work. So, I reinstalled the Centos7.7 and root ,the root command still couldn’t work. The same error occurred as the title. Then I tried both of the steps you suggested,it finally worked. I think maybe I made some mistakes in the previous installation.
thanks a lot for your advice ,you really did me a big favor.
I’m Chinese and excuse me if my English is not good.
Wish you have a nice day!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.