Problem with MSVC install directory

I thought the following way of installing the Root was the easiest one but actually I have a problem.
I run windows vista and even I start IDE on my own and as administration mode when I specify all the required field at “ROOT build builder” and press generate the following message always appears:
"unable to find MSVC’s directory; you will have to start it your own"
What am I doing wrong? What else can I do?

root-builder attempts to guess what version of the IDE you have installed. For whatever reason, it is failing to find yours.

To work around can you try the following: Select the proper IDE version from the drop-down list, generate, then find the solution file (which is placed in ROOT’s base directory) and double click it. You should then be able to hit build.

What version of the IDE do you have? Pehaps there is a version I’ve not tested on. I check the registry to try to figure out what version is installed and perhaps your version has a different signature that I’m not correctly detecting.

Vista isn’t the problem – the code was actually written on Vista and then back-ported to XP. I don’t run the IDE in admin mode, so I don’t think that is connected to your issue.


There are 3 IDE versions (2003, 2005, 2008). I have have tried to generate the project with every one of them but still no result.

What version of the IDE do you have installed? What one do you want to try?

What do you mean by “no result”? There was no solution file?

I installed 2003 edition and when I press generate project the following message appears:
"unable to find MSVC’s directory; you will have to start it your own"
I can’t find the solution file

So, if you’ve downloaded and extracted all the root source to c:\root, then I would have expected the solution file there. I’ll try running it here (I’m not near a VM with VS 2003, so I can’t fully test this right now).

Ok, I don’t have 2003 installed on my machine, so I can’t test that I can build in 2003, but I think I see your error.

The first thing to know – ROOT Builder takes very little time to do its job.

Lets say you’ve downloaded the source code to c:\root. Then do the following:

  1. Start root biulder
  2. Fill in the ROOTSYS as “c:\root”
  3. Make sure the drop down says “2003”.
  4. Uncheck the “start IDE”

Then click “Generate Project”. It will take one or two seconds, and then it will close.

  1. Open “c:\root” in the explorer.
  2. Double click the file “root_build_project” file
  3. Build

and that should work just fine.

I don’t know why things aren’t working automatically (i.e. why it isn’t starting up the IDE automatically). I’m at a meeting now and won’t be back near my development machine for this stuff until this weekend. I’ll test out 2003, and, more importantly, see what my code does to find this location and give you some other things to test.

I hope this helps.


I built it
I appreciate your help

Great! This weekend I’ll try to track down the “could not start” error you were seeing. I may need your help then to repro it.