Problem with installation Sierra 10.13.2


I try install root_v6.11.02 in my MacXO
version High Sierra 10.13.2

I have this version of Xcode

XcodeDefault.xctoolchain/usr/bin/cc --version
Apple LLVM version 9.0.0 (clang-900.0.39.2)
Target: x86_64-apple-darwin17.3.0
Thread model: posix
InstalledDir: /Applications/

I have this problem:

[ 52%] Performing configure step for 'LZMA’
CMake Error at /Users/andrea/Desktop/root-6.11.02/build/LZMA-prefix/src/LZMA-stamp/LZMA-configure-RelWithDebInfo.cmake:16 (message):
Command failed: 1

‘/Users/andrea/Desktop/root-6.11.02/build/LZMA-prefix/src/LZMA/configure’ ‘–prefix’ ‘/Users/andrea/Desktop/root-6.11.02/build’ ‘–libdir’ ‘/Users/andrea/Desktop/root-6.11.02/build/lib’ ‘–with-pic’ ‘–disable-shared’ ‘–quiet’ ‘CC=/Applications/’ ‘CXX=/Applications/’ ‘CFLAGS=-Wno-format-nonliteral’ ‘LDFLAGS=-Qunused-arguments’

See also


I report the file:

andreas-Mac-Pro:build andrea$ more /Users/andrea/Desktop/root-6.11.02/build/LZMA-prefix/src/LZMA-stamp/LZMA-configure-*.log
configure: error: in /Users/andrea/Desktop/root-6.11.02/build/LZMA-prefix/src/LZMA': configure: error: cannot run C compiled programs. If you meant to cross compile, use–host’.
See `config.log’ for more details

XZ Utils 5.2.1

System type:

Configure options:

Initializing Automake

Thank you

Best Regards


Hi Andrea,

could you give a try to the latest root version, 6.12.04? 6.11 is a development release which preceded that one.


Hi, I tried it with 6.12.04 and had the same error. Same version of OSX and XCode.

Me again. Just did “xcode-select --install” and was surprised to see that it had something to do. Thought everything was up to date. Anyway, solved this issue and it is now compiling. Hopefully successfully.

As reported here, I also got problem in compilation, with the head of ROOT. Is there some workaround on the latest MacOS, 10.13.2?

Thanks a lot!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.