Problem with fonts?

Hi all,

this is a pretty weird (though certainly minor) issue I am getting, which regards fonts in a canvas plot: axes titles, labels, stats, legend etc…

I have two installations of ROOT 5.28.00c in the same cluster. Whit installation-1 I get normal fonts, just like the examples in ROOT guide. Whereas with installation-2 I get very weird italics fonts, which cannot be changed neither in type not in size. Moreover, special characters such as greek letters are printed in latin, thus e.g. #nu gives “n”. You can see this in the figure attached (notice that the editor says helvetica bold, but the y-title does not look helvetica).
This thing is annoying because those fonts are ugly and cannot be edited in any way.

Anybody has a clue?


this sounds rather odd.
Are the binaries coming from the same source? Is the environment in the two cases identical?


Hi, thanks for answering,

The environment looks identical in the two cases, except for the ROOT related stuff in ROOTSYS, LD_LIBRARY_PATH and PYTHONPATH.

For what regards the binaries, I would say that installation 1-good has been installed using binaries (it’s a common installation in my group in cc-lyon), whereas installation 2-bad was compiled by me with these config options: -disable-castor --disable-fftw3 --disable-rfio --enable-roofit (actually I need it in order to use roofit).

Can you post the exact “configure” and “make” lines that you used for your “private” ROOT installation.

What concerns the “group in cc-lyon” installation, can you post where exactly this ROOT is installed:
root-config --prefix
root-config --etcdir

yes sure.

For what regards the common installation:
root-config --prefix : /afs/

root-config --etcdir : /afs/

For my private installation:

configure options:
–with-pythia6-libdir=/sps/km3net/users/galata/Software/lib --prefix=/sps/km3net/users/galata/Software/src/root-v5-28-00c/INSTALL --etcdir=/sps/km3net/users/galata/Software/src/root-v5-28-00c/INSTALL/etc --disable-castor --disable-fftw3 --disable-rfio --enable-roofit

for the make lines, I didn’t give any specific options, just typed the classic
make install

One more question.
Before running “configure” (and then “make”), did you make sure that nothing in your shell’s environment points to another ROOT version? In particular did you “unset ROOTSYS”?

P.S. See [url= old notes about building ROOT[/url] and [url= of my old examples[/url].

Actually I am not sure.
I will build it again with a clean environment and let you know.

I recompiled it twice,

  • the first time with the ROOTSYS (and root lib and pypath) pointing to the actual installation I was compiling
  • the second time with the “root environment” completely unset

and nothing changed.

I did a:

make uninstall
make clean
make install

both times.

Did you also run “configure” twice?
Note: you should run “make distclean” or maybe better “make maintainer-clean” before the new “configure” step and If you use “–prefix” then “unset ROOTSYS” first.

BTW. For both your ROOT installations, you could also compare the output of:
root-config --config
root-config --features

I tried , but I still get the problem.
I did:

make maintainer-clean
unsetenv ROOTSYS
./configure (same options as above)

make -j2
make install

I also checked the features and config options, indeed there are differences, but I don’t know what they mean. I’ll try to compile using the same options, later on. I’ll let you know.

Well, my idea was that you post the output of “–config” and “–features” here so that we can have a look at them (in particular I would check if the “xft” feature was enabled).

Another idea … compare the contents of the “root-config --etcdir/system.rootrc” files for both installations … and if the “xft” feature was enabled by configure, change “X11.UseXft:” to “yes” (the default is unfortunately “no”).

Yet another idea … can it be that you have “${HOME}/.rootrc” and/or “./.rootrc” and/or “./rootlogon.C” files (they may contain installation specific modifications which are valid for one of them only)?

ok, thanks, so they are below

root-config --features:

my install:
asimage astiff builtin_afterimage builtin_ftgl builtin_glew builtin_pcre cintex clarens editline exceptions fitsio genvector krb5 ldap mathmore memstat mysql odbc opengl peac pythia6 python reflex roofit shadowpw shared ssl tmva x11 xft xml xrootd thread

group install:
asimage astiff builtin_afterimage builtin_ftgl builtin_glew builtin_pcre editline exceptions fitsio genvector mathmore memstat minuit2 opengl python rpath shared soversion tmva x11 xft xml thread

root-config --configure:

my install (same as above) : --with-pythia6-libdir=/path --prefix=/path --etcdir=/path --disable-castor --disable-fftw3 --disable-rfio --enable-roofit

group install:
–disable-monalisa --disable-oracle --disable-peac --disable-pgsql --disable-afs --disable-alien --disable-chirp --disable-xrootd --disable-ruby --disable-sapdb --disable-ssl --disable-roofit --disable-rfio --disable-shadowpw --disable-cintex --disable-srp --disable-sapdb --disable-qt --disable-qtgsi --disable-peac --disable-table --disable-gfal --disable-globus --disable-mysql --disable-ldap --disable-krb5 --disable-odbc --disable-reflex --enable-soversion --disable-builtin-zlib --disable-clarens --with-gsl-incdir=/afs/ --with-gsl-libdir=/afs/ --enable-minuit2 --with-pythia6-libdir=/afs/ --disable-rfio --disable-castor --disable-fftw3 --enable-rpath

Well, I can see no problem in the output.
I think you could add “–enable-minuit2 --enable-soversion” to your configure line.

You do have “xft”, so try to modify your “root-config --etcdir/system.rootrc” file (change “X11.UseXft:” to “yes”, no need to recompile ROOT afterwards, just run “root” again).