Problem submitting a HTCondor job of running a root macro

I am not sure if this is correct place for asking my doubt since it is more related to HTCondor than with root itself.

I have a root macro named “test_tt.C” in a directory in my ssh account. If i run it locally with “root -l test_tt.C”, it takes a VERY long time because i am running over a lot of events. But the code is free of errors. So, i tried submitting the job to HTCondor as explained in the tutorial below.

Based on the tutorial i made two files.
I named one file “” which contains the commands to be executed. It contains the following code:

export SCRAM_ARCH=slc6_amd64_gcc630
cd ${CMSSW_BASE}/src
cd -
root -l test_tt.C

The second file i named as “job_submit.sub” which will actually tell the HTCondor about submitting “”. It contains the following code:

executable              =
log                     = job.log
output                  = outfile.txt
error                   = errors.txt
should_transfer_files   = Yes
when_to_transfer_output = ON_EXIT

I submitted the condor job but it got errors. The “errors.txt” file is attached.errors.txt (1.9 KB)

Sorry if the question is off topic or missing any essential details, in which case kindly tell me.

As you said, it is a HTCondor-relayted issue. Please ask to the HTCondor community.