Problem setting $PATH and $ROOTSYS


I’ve installed ROOT referring to User Guide 5.16 and it worked, but next day when I tried running ROOT again it didn’t find it installed. At first I thought that it was because I was not signed in as SUDO user, but when I did sign in as sudo I wasn’t able to start it from terminal either.

Next thing I tried checking was $ROOTSYS and $PATH, but there wasn’t $ROOTSYS at all and in the $PATH there wasn’t path to folder in which I installed ROOT. Of course I set these variables once again and then ROOT worked just fine. But when closing that terminal window and reopening terminal again and trying to run ROOT I got once again error message that ROOT isn’t currently installed.

Can someone help me with this problem?

Thanks in advance.


you have to add to your .bashrc the following lines:
export ROOTSYS=/path_where_you_installed_root/root
export PATH=$ROOTSYS/bin:$PATH

You can find the hidden file in your home directory.

I did all those things and it works, but when I close that terminal window and open another one, everything that I did is like forgotten.

Typing this line into new terminal window

gives me no output. I’ve tried finding $ROOTSYS but it doesn’t exist.

And when I type in

# echo $PATH

in the output line there is no path to root which I added with line

export PATH=$ROOTSYS/bin:$PATH 

I think that problem in my case is making these changes permanent. I don’t know why my computer forgets those changes that I made to $PATH and why he forgets that $ROOTSYS was defined.
Also could you tell me what is the name of the hidden folder in my home folder that I should be looking for.

Btw I have forgotten to say that I’m using Ubuntu 9.04.

It’s strange, i’ve ubuntu 9.04 too and i’ve made this things and all works fine. … if you modify the hidden file bashrc and add the line that i’ve posted you can find the $ROOTSYS variable every time you open the terminal that you can find in Applications menu.
If you open another terminal that use another config file you’ll don’t find the variables.
But you have to be sure that you modify the correct bashrc file that you find in your home directory, if you want to have setted the variables for a root (super user ) session you have to add this same lines in the bashrc present in the root home directory.

Sorry if my english is not the best :slight_smile: