Problem saving canvas as pdf - example

Dear MacRooters

It seems that my attachment is too large for roottalk, so I am trying
to send the attached test macro and test file to this forum.

Can someone reproduce the problems when running the macro and
saving the canvas as pdf-file?

Thank you
Best regards
Christian

cstrato wrote:

Dear Olivier

I have tested my example again on Mac OSX, and on the Mac it is
reproducible, both with Adobe Reader 6.0 and with Apple´s Preview.

When trying to open it with gv on the Mac, I get the following
GhostScript Message:
Error: /invalidfileaccess in --file–
Operand stack:
(/Users/rabbitus/ROOT/rootcode/xpsx/c1.pdf) ®
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-

I hope that this message may be helpful.

P.S.: It seems that my mail with the example did not appear in
roottalk although I have sent a cc to roottalk ,so I will try to
send it again with separate mail so that other MacRooters could
try to reproduce it.

Best regards
Christian

Olivier Couet wrote:

Hi Christian,

Thanks for your example. I have tried it with ROOT 4.01/01 on my linux machine. I have generated a PDF file from the “File” pull down menu in the canvas menu bar. I can visualize the generated file without any problems with: acroread version 5 and gv on my linux machine and with acrobat reader version 6 on an XP machine. Note that I saw the problem with the file test.pdf you previously sent me (you had generated it with ROOT 4.00/08). Looking at the recent changes in TPDF, I do not see one which could have fixed a such problem. It is difficult for me to debug this without a macro reproducing the it, because the error message you get comes from a binary compressed part of the PDF file. So to debug it I need to regenerate the file without compression.

Cheers, Olivier

On Mon, 19 Jul 2004, cstrato wrote:

Dear Olivier

Enclosed is a short macro and the input data. Initially, I
could not reproduce the problem with pdf, but when I added:
gStyle->SetPalette(1,0);
then the problem is reproducible.

Best regards
Christian
test.tar.gz (118 KB)

HI,

This problem has been solved in the CVS repository.

Cheers,
Philippe.