Problem running root remotely


I am accessing the fermi natl. laboratory from a remote terminal (a Linux machine using the newest version of Fedora 3) using OpenSSH 3.9, but I’m unable to get root to run on any data files there. I am working through the tutorial there ( … CMKIN.html ), but when I try to run it:

$ root
root: can’t figure out DISPLAY, set it manually

I’m new to Linux, and I’m unsure of how to set DISPLAY, or even whether I’m supposed to set it on my machines, or on theirs after I’ve logged in. I have root v. 4.02/00 installed and running fine on my local machine, but not through SSH on their servers.

Any help would be greatly appreciated.

use ssh -X, or add the line “ForwardX11 yes” to your ~/.ssh/config (if it doesn’t exist, copy /etc/ssh/ssh_config to ~/.ssh/config, and then add the line). This has nothing to do with root, it’s ssh and x forwarding (in case you want to use man ssh or google to find out more details).

Ah, I hadn’t realized I needed to tell ssh to enable X11 graphics.

Thank you so much, everything is working perfectly now.

I encountered similar problem and what I found was that sometimes for certain machines with certain ssh versions one
needs to say:

ssh -X -Y to make X11 things work.