Problem running ROOT on Windows after installation

ROOT Version: v6.28.00
Platform: Windows 10
Compiler: Visual Studio 2022


I’ve tried to install ROOT using the Windows 10 x64 .exe provided for the latest version. I did install beforehand Cmake and Visual Studio 2022. Installation seems to go smoothly, but when I try running ROOT from the .exe, I only get a command prompt blinking on the screen. To have a look at the error message, I tried running it directly from the VS 2022 command prompt and got the following errors:

…which I do not understand at all. The problem persists after several reboots and re-attempts to install.

Note that I am almost entirely ignorant of command prompt installation procedures and would have no idea how to proceed from the bin files (and much less from the source files)…

Welcome to the ROOT Forum!
Make sure you have selected the Desktop development with C++ in the Visual Studio installer, with the proper Windows SDK, and then you have to start ROOT from within a x64 Native Tools Command Prompt for VS 2022

That worked, thanks!

1 Like