Problem packaging ROOT as a rpm

Hi, I am trying to install ROOT as module on our cluster. All I need to do is write up a spec and package it as a rpm so that the admin will install it throughout all the compute nodes. In the spec file, I wrote:

./configure --prefix=%{INSTALL_DIR} --disable-rfio --disable-ldap --disable-xrootd --disable-krb5 --disable-ssl
make -j4

When I run rpmbuild, I got the following error:

error: Installed (but unpackaged) file(s) found:

All the files installed under $ETCDIR can’t be rolled into the rpm.

At first I thought it is because etcdir is somewhere else as other files. So I modified configure and changed etcdir to $prefix/etc/root. Didn’t help. Than I added --etcdir=%{INSTALL_DIR}/etc/root while running configure and still the same error.

Need some advice. Thanks.

I successfully create ROOT rpms on a regular basis. I’ll have a look and let you know how I do. I can attach the spec file here. Be warn however that it is an old rpm spec that might have a lot of ugliness in it…

What would be grand is to be able to use CPack to package ROOT. Maybe is it possible ?


Please find attached the spec file we use and the bash script we launch to build the rpm. We need only to change the variables in the script to build a different version.

However, please note that we use cmake and not configure !

Now, specifically about your error : the %file section doesn’t match the %install section. Try to add /etc/root/ in %file or make sure to remove them in the %install.

I hope it can help you.


PS: apparently I can’t attach .sh and .spec files, thus the .txt at the end of the files. You should remove the extra extension. (811 Bytes)
root-cmake.spec.txt (2.59 KB)