Problem on reading from Ansys and COMSOL

As the title, I tried examples Gem and Comsol, the origin examples worked well, but when I replaced the field file with my own (I only used the part of reading field process in examples), they did not work.
I want to know if it is the problem with the field files. Following are the field files I used. (997.3 KB)
The ansys file is too big, so I made a shared link following.

Your Comsol field map uses a linear tetrahedral mesh (4 nodes per mesh element). The ComponentComsol interface only works with quadratic tetrahedral meshes (10 nodes per element) at the moment. I’ll put it on our to-do list to add the possibility to also read linear tetrahedral meshes, but for the time being the easiest solution is probably to re-run Comsol and use a quadratic tetrahedral mesh.

I didn’t manage to download the Ansys files (I don’t know which button to click on after following the link you sent).

Sorry for my negligence about Ansys file.
I upload it again by WeTransfer.

I’m also trying your suggestion about Comsol.
Thanks for your reply!

Thanks a lot for your solution.
By following your advice, Comsol field file can be read correctly by Garfield++.

sorry for the delay. I downloaded your ANSYS file, and the import works fine for me.
Can you make sure you have the latest version of Garfield++ and try again?

Thanks for your test.

My Garfield++ was installed recently, I can not make sure it’s the problem of version or some other things wrong. I will try your suggestion and give my feedback.

Thanks again for your patient reply!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.